What's new

Firmware Update shows at last - guess what? I can't install it!


New Member
So I had been plagued with power-related issues whereby my Surface Pro 2 says "plugged in, not charging".

MS Support, forums, online research suggested:

- unplug and re-plug the power
- leave the Surface to discharge fully then leave it on to charge booted into UEFI overnight
- check powercfg -batteryreport
- do a system refresh

None of the above helped! My Surface Pro 2 switches off as soon as you remove the power, and simply doesn't say it's charging. If you turn it on without the power in, then it says "plug in immediately" but carries on for a long time. So the battery is physically charging - but the system is not recognising the fact.

Last week MS Support told me the Firmware Update was due, so I should hold-off until then.

Well it took until LAST NIGHT for the thing to show up for me!

And when I go to install it? Guess what.

It requires me to charge the battery before I can install it.


Shut down your tablet. Hold the vol + and the pwr button for 30 sec. The surface logo will flash etc. but keep holding. After 30 secs, let go and wait 10 sec. Then turn it on again. This should reset your charge indicator so you can install the update.
Try downloading the FW, unpack it, and then install it with "pnputil -i -a [filename].inf"
That may bypass the battery check.

Try the hard reset described by Ruffles -- if that doesn't work I can tell you a handful of other things to try.
Hi both, thanks for your comments.

Ruffles - I tried your suggestion and it worked. Battery indicator now shows full and I was able to install the firmware update.

And thanks drolem for your comment - useful to know for the future...

The problems appear to have abated for now - let's hope my specific problem is solved by the firmware update. After all, I haven't seen any evidence that the "plugged in, not charging" issue was actually solved by this update! (Correct me if I'm wrong.)