What's new

For those who are having WLAN Issues - (Possible Fix - Tested for the last 48 hours)

kristalsoldier

Well-Known Member
hi I am new to the forum. Registered here because of the bugs I have... infact this is one of the 2 annoyances I have with the device. Apart fromthis, I love it!

Can someone please confirm to me that this is working for them? I live in the UK and have no way of getting a broken device back to warranty back in the US :) yey for me.

I have 2.4Ghz connecting at about 40Mbit and 5Ghz just wont behave at all. I am using a BT homehub 5 which is a dual band AC router. The 5Ghz connects at about 6Mbit but really it isn't connected even though I get issued an IP.

Wait a sec...why won't your warranty that came with the SP3 that you presumably bought in the US also apply in the UK? It has an international warranty by default, doesn't it?
 

JesseDiaz

Member
Mine seems to be working good. I installed the driver directly from my location on the hard drive as Jeff noted.....I split the screen and had my WIFI STATUS up while I did Speediest.net. Before I did the test my speed for the adapter noted 6.0. When the speed test started, it jumped to 300.0 Mbps. I did this a few times and had the same results.
I was on battery connected to a 5ghz wireless router connection.

upload_2014-7-1_22-17-19.png
 

Attachments

  • upload_2014-7-1_22-16-55.png
    upload_2014-7-1_22-16-55.png
    21 KB · Views: 478

EddySnoozah

New Member
I'm in the UK and have a friend visiting the US for a couple of weeks. I asked her to order a Surface Pro 3 for me and she mailed last night to say that it arrived. Before I ask her to turn it on to check that it works (she has my MS log on details) should I tell her to say no to any requests to install updates or firmware? If it is the case that it is the update that is causing issues for some people, then presumably I should be able to avoid any potential WLAN issues by holding off on updates until MS get a fix out for this thing?
 

ctitanic

Well-Known Member
Here is another trick that seems to help.

Enable Hyper-V to expose advanced power options settings, restart, open power options, click change plan settings, click advanced settings, expand wireless adapter power settings, change to max performance. Disable Hyper-V and restart. Now connects everytime and fixes connection speed display​
 

pcom

New Member
Here is another trick that seems to help.

Enable Hyper-V to expose advanced power options settings, restart, open power options, click change plan settings, click advanced settings, expand wireless adapter power settings, change to max performance. Disable Hyper-V and restart. Now connects everytime and fixes connection speed display​
This seems to have done it for me. I've only been through one sleep cycle but I don't believe I made it through ANY cycles before. And it would explain why people don't have problems when plugged in -- the power saving settings are set to maximum performance when plugged in. I'll keep my eye on it for a few days.

EDIT: To be precise and document the steps I took, I first enabled Hyper-V, rebooted, changed my power plan, made sure I was connected to my AC router, rebooted, made sure I was still connected to my AC router, disabled Hyper-V and rebooted. I checked again to make sure I was still connected to my AC router then let it go to sleep. When I woke it up, I remained connected.
 
Last edited:

Nursedad

New Member
I just made this change per your instructions as well. Interestingly enough...tonight this issue hit me like a ton of bricks. First time this has happened to me. Surface was asleep, off battery and totally wouldn't connect to my AC router.

Will post tomorrow after a few off power sleep cycles.
 

greatg

New Member
Here is another trick that seems to help.

Enable Hyper-V to expose advanced power options settings, restart, open power options, click change plan settings, click advanced settings, expand wireless adapter power settings, change to max performance. Disable Hyper-V and restart. Now connects everytime and fixes connection speed display​
Just wondering why you would disable hyper-v after making changes? I also noted that under these advanced power options "sleep" is no longer an option - only hibernate?
 

malberttoo

Well-Known Member
Just wondering why you would disable hyper-v after making changes? I also noted that under these advanced power options "sleep" is no longer an option - only hibernate?

My guess it that Hyper-V probably makes changes to your SP3 that you wouldn't necessarily want unless you were actually running a virtual machine on it.
 
OP
jnjroach

jnjroach

Administrator
Staff member
Just wondering why you would disable hyper-v after making changes? I also noted that under these advanced power options "sleep" is no longer an option - only hibernate?

Sleep (of any kind) is not supported in any hardware based Hypervisor as it would leave the Virtual Workload in an unstable state. Hibernation writes all RAM to disk.
 

pcom

New Member
This seems to have done it for me. I've only been through one sleep cycle but I don't believe I made it through ANY cycles before. And it would explain why people don't have problems when plugged in -- the power saving settings are set to maximum performance when plugged in. I'll keep my eye on it for a few days.

EDIT: To be precise and document the steps I took, I first enabled Hyper-V, rebooted, changed my power plan, made sure I was connected to my AC router, rebooted, made sure I was still connected to my AC router, disabled Hyper-V and rebooted. I checked again to make sure I was still connected to my AC router then let it go to sleep. When I woke it up, I remained connected.
It's been less than 24 hours but I thought I'd post a quick update -- I've let my tablet sleep 4 or 5 times and have always gotten WiFi back.
 

ctitanic

Well-Known Member
Just wondering why you would disable hyper-v after making changes? I also noted that under these advanced power options "sleep" is no longer an option - only hibernate?
If Hyper V is enabled you will loss Connected Standby.
 

tuchas

Active Member
If Hyper V is enabled you will loss Connected Standby.

Frank, I don't know about anyone else, but I don't think Connected Standby works. Well - let me rephrase that. I think Connected Standby is interfering with processes on the Surface and it's causing strange behavior. I took a look at my event log this morning and saw some really weird stuff - lots of system errors. First, I saw this log entry about 45 minutes after closing the type cover:

Marvell AVASTAR Wireless-AC Network Controller : Has determined that the network adapter is not functioning properly.

Then, the next minute I saw a series of about 20+ log entries with this error over the course of the next hour:

The server {1EF75F33-893B-4E8F-9655-C3D602BA4897} did not register with DCOM within the required timeout.

Two hours later, I got the following log entries that were a second apart:

A timeout (30000 milliseconds) was reached while waiting for a transaction response from the WSearch service.

The system is entering sleep.
Sleep Reason: Battery


Then I have to assume the unit went into hibernation. This morning I opened the type cover and had to press the power button to get it going. I saw the Surface logo as if I was booting up (maybe I was).

But I had rolled back to the older WLAN driver and did not experience slowdowns at all today. All I can say is something is amiss and needs to be addressed ASAP. Turning on Hyper-V is not a solution - besides I will not be able to run a VM on this unit if I do that.
 
Top