What's new

Handwriting recognition problems in browsers


New Member
Just upgraded from a Surface Pro 2 to a Pro 3. Mostly, I'm very happy but lam still having a really irritating problem when I want to search in a browser.

If I try to handwrite a search term in the omnibox in Chrome, the handwriting recognition assumes that I am writing a URL (which I basically never do) and runs all my words together, introducing numerous recognition errors in the process.

I have tried used Canary, tried Chrome on both Desktop and Windows 8 modes, and even tried Internet Explorer (yuk!), but l get the save problem with each one. So, this seems to be a Surface. Pro issue, not browser specific, and it has persisted from version 2 of the Pro.

Has anyone else seen this and, if so, is there a fix? I only use the pen with my Surface (that's what I bought it for), so it's really annoying not to be able to do simple Internet searches.

Thanks, Jim


Well-Known Member
Afraid I can't be of much help. I use IE 99% of the time but I went to Chrome and keyed in Omnibox in the Google search window to see if I could fine out what Omnibox was and it appears to have something to do with TV so it must not be what you're talking about.

Frankly, I didn't know you could use the pen to write in a browser. Can you key in text into the search window OK and it recognizes what you're searching for?


New Member
"Omnibox" is simply what Google calls the place where you type in a web address: a few generations of browsers ago, they all had one box for the address (URL) and another for search terms. Chrome was the first (l think) to merge these into one so that you could just type whatever you were searching for. The problem I am facing is that when I use the stylus and the handwriting recognition to write in a search term, the Surface always treats it as a URL. So, I have to open the Google homepage and type in the search box. Not the end of the world, I realise, but I would like new gadgets to make life simpler, not slightly more complex. Jim