What's new

Like a fool, I updated now my SB2 15 inch doesn't have a dGPU

chekhonte

Member


I can't install a driver and it doesn't appear in the device manager. I'm such an idiot for updating to the creators update day one.
 

GreyFox7

Super Moderator
Staff member
Settings - Update & Security - Recovery - Go back to the previous version of Windows 10.
 

bangsters

Member
I just noticed that mine does the same. I cannot roll back.

How can we check if dGPU is enabled? Mine is 15" with dGPU. I can't see it in taskbar.

If I go to Device manager, I see both display adapters. But if I recall on my older SB1, there was an option to specify which adapter to use. I can't seem to find it with the SB2. Normally I think we just right click on desktop and there is an option there, or in taskbar? I don't see any.
 

jnjroach

Administrator
Staff member
I had the same issue....try this...hold volume rocker up and press the power button for a full 30 seconds past the "Slide Down to Shutdown", then it will switch into a diagnostics mode, allow it to restart and that should force the NVIDIA GPU to be redetected. It worked for me during the Insider Builds.
 

bangsters

Member
Tried it didn't do anything for me. Also tried updating via Windows Update. No go as well.

Now currently downloading WHQL drivers from nvidia site. Will post update shortly.
 

jnjroach

Administrator
Staff member
Tried it didn't do anything for me. Also tried updating via Windows Update. No go as well.

Now currently downloading WHQL drivers from nvidia site. Will post update shortly.
Sorry - my fix is for the disappearing dGPU - yours is the update with Windows 10 Spring Update. It is now included into the Settings - System - Display - Graphics Settings
upload_2018-5-1_7-46-9.png


If you want the NVIDIA settings you can install the January WHQL Drivers (February and later wouldn't install directly) and from the GeForce Driver Updater I could get the March Drivers to update (April's errored out).

upload_2018-5-1_7-49-39.png
 

bangsters

Member
Thanks!! I found that setting, so they moved it lol.... is there any advantage to installing the WHQL drivers, or better to keep it default?
 

jnjroach

Administrator
Staff member
Thanks!! I found that setting, so they moved it lol.... is there any advantage to installing the WHQL drivers, or better to keep it default?
The default will always be tuned for the device and offer better battery life. But some games will need the newer drivers...
 
OP
chekhonte

chekhonte

Member
I had the same issue....try this...hold volume rocker up and press the power button for a full 30 seconds past the "Slide Down to Shutdown", then it will switch into a diagnostics mode, allow it to restart and that should force the NVIDIA GPU to be redetected. It worked for me during the Insider Builds.
Device manager shows my dGPU but I still can't install the update but that will still tide me over until the fix for this problem since I don't need the newest driver for now. Thanks for the tip!
 

jnjroach

Administrator
Staff member
Device manager shows my dGPU but I still can't install the update but that will still tide me over until the fix for this problem since I don't need the newest driver for now. Thanks for the tip!
January's WHQL was the last one the was compatible with the SB 2 from a straight install. I was able to install that one and then it updated to the March Driver. The April update fails.

I was able to force the April Driver but it caused many stuttering issues so I guess I should believe them :D
 
Search tags for this page
azs
ms 15 incg sb

news

Members online

No members online now.
Top