What's new

Micro SD Support on RT???

MikeSD

New Member
You'll always have less total storage, if you start of with a 32G Surface. Whatever you can get by adding microsd, you could have 32G more, if you had a 64G Surface.
 

Marco

New Member
Ok, I got the SD Card to mount as others have mentioned. It did work, but there is a bug in the Video Player App on how it reads from the Video Library.

Here are the steps I used to mount the SD Card:
1. On the SD card create a folder called "Program Files" (D:\Program Files)
2. Create a SD folder in the Windows folder Program Files (C:\Program Files\SDCard)
3. "Right-Click" the Computer Icon (or hold your finger over it and then release it) to bring up a menu window and select "Manage"
4. Select "Disk Management.
5. In the middle-top area of the window, under volume, right-click the SD Drive (New Volume (D: ) and select "Change Drive Letter and Paths..."
6. In the new window, select "Add"
7. In the next new window, select "Mount in the following empty NTFS folder" and then browse to the folder you created in step 2 (C:\Program Files\SDCard)
8. Hit OK twice and exit "Computer Management".

That mounts the SD card. I found those instructions online. It's not clear to me that step 1 actually does anything. When you look in C:\Program Files, the SDCard folder now has a shortcut icon and inside it has all the folders on your SD Card.

Now create a SD video folder that will become part of the Video Library:
1. On the SD Card, create a folder called "SD Video"
2. You may want to put your movies into the folder now before doing the remaining steps or you may run into the bug described below.
3. On the left side of File Explorer, select Library->Videos
4. At the top of the window, select the "Manage" tab, select "Manage Library" and then "Add"
5. You need to select the SD Video folder by browsing through the C Drive path to get it to work (C:\Program Files\SDCard). If you get to the SD Video by way of the D Drive path, you will get an error message about it being a removable drive. If you go through the C drive path, it works fine, even though either way it is the same folder.

Ok, you are done. Now test it out:
- Hook up a portable USB hard drive or other method and copy a couple of movies to the SD Video folder.
- Go to the Video App and open it up. Under "my videos" on the left, the movies should show up. It will only show up to 3 here. If you have more than that, they will show up when you select "my videos". If it is all correct, then you will see the movie "picture" with the filename title to the right of it. They will show up as "all" or "other" selected but not if "movies" is selected. I assume that movies you by from MSN/XBox have some kind of tag that makes them show up as "movies". I haven't figured out how to make this tag for movies I already have from other sources.

Here's where the Video app bug comes into play for me. Try adding another movie to the SD Card, Open up the video app, and it doesn't show up for me. There appears to be some sort of "memory" of the titles it thinks are in that folder. Once it gets set, it seems to be frozen and never update.
I moved the movies to an alternate folder and then removed SD Video from the Video Library. The Video App then showed no movies which is OK. I added the empty SD Video folder back into the Video Library and opened up the Video App, and it shows the movie "tiles" again even though the folder is empty. If you click the movie tile, an error message says "Cannot find file" which makes sense. I resolved this by creating a new folder called SD Video2, putting the old and new movies in it, and then adding that folder to the library and making sure that the old "SD Video" folder is not in the library. The Video App then shows all the movies correctly for me.
Bottom line: If you make a folder with 10 movies and never change it, it works fine. Every time you add a new movie to an existing SD movie folder, the video App will not show it correctly. You can work around this the way I described. You could also probably create a new folder every time you add a new movie and add that folder to the video library to work around the bug in the Video App.
 
D

dvdcatalyst

Guest
the added movie not showing up in the library might be related to the indexing service.

In your case, go to the desktop, then tap and hold (or rightclick) on the program files\sdcard folder and select properties. then enable "allow indexing"
 

Br1an_g

New Member
I am having a few issues with my 64Gb card. seems that every time I try to write files to the card it fails with an error. I repair and it works for a while before failing again..

dodgy card? or should I try formatting it first?
 

Br1an_g

New Member
the added movie not showing up in the library might be related to the indexing service.

In your case, go to the desktop, then tap and hold (or rightclick) on the program files\sdcard folder and select properties. then enable "allow indexing"

I don't see an allow indexing option..
 
D

dvdcatalyst

Guest
I am having a few issues with my 64Gb card. seems that every time I try to write files to the card it fails with an error. I repair and it works for a while before failing again..

dodgy card? or should I try formatting it first?

Likely the card. I picked up a Sandisk one from Amazon last week for my Surface, and was experiencing similar issues. With me, it was video files that were fine, but when copying over to the card, some worked, some didn't. After a format and transferring the files again, others broke, and the ones that didn't work before worked fine then.

I don't see an allow indexing option..

In advanced, sorry. It might already be enabled.

But, rather than using the program files location, maybe try creating an sdcard folder in the videos folder in your user account, and mount it in there?
 

J515OP

Super Moderator
Have you checked the video app settings to see if there is an option to scan for media and possibly setting on when it does this (i.e. scan each time the app is opened)?
 

Br1an_g

New Member
Likely the card. I picked up a Sandisk one from Amazon last week for my Surface, and was experiencing similar issues. With me, it was video files that were fine, but when copying over to the card, some worked, some didn't. After a format and transferring the files again, others broke, and the ones that didn't work before worked fine then.



In advanced, sorry. It might already be enabled.

But, rather than using the program files location, maybe try creating an sdcard folder in the videos folder in your user account, and mount it in there?

i followed the guide on winsupersite.
created c:\SD
mounted my SD card in there
created folders in my SD for each media type and the added them to my libraries.

don't have an advanced option on SD or the mounted folder and not seeing my files in the libraries..
 
D

dvdcatalyst

Guest
Supposedly this should work:

Team Radicus | Surface and SD Card

I haven't gotten to try it myself yet, but the article describes to create folders on your SD, and mount those to folders on your c-drive, then add those folders to the indexing options.
 
D

dvdcatalyst

Guest
Glad to hear it :)

Last weekend I tried something similar, but couldn't get it to work. I ran into that article yesterday, but didn't have time to play with it.

When you add new files, does it update in the library now?
 

Members online

Top