What's new

more weird problems: black screen on boot / wake from hibernate


New Member
gah! this is the most weird thing ever.

melodrama aside - recently the screen will sometimes do either of the following:

1) when hibernating and I press the power button, the unit will turn on (the touch Windows button will vibrate the unit or the keyboard backlight will light up) but the screen stays black
2) the screen will show the Surface boot-up logo (the spinning dots) normally but then fail to transition to the login screen and just stay black.

I usually have to hold the power button for 15s to turn the thing off and then when I turn it on again it will boot up ok. I've checked the Windows reliability monitor but all it says is 'windows did not shut down properly'.

note that this ONLY happens when waking up from hibernate. has this happened to anyone else? thanks again!


New Member
Might be an obvious point, and I apologise if I'm stating something you know already, but have you checked and double checked for updates & firmware updates? And have you got Hyper-V enabled?


Active Member
I have this issue too (started after one of the recent updates) but I'm dual booting Win8.1 and Win10. Thought it was a issue with Win10 not showing the boot menu (discussed in another thread brought up by razy60) but maybe not.


Nope, just properties of your c-drive, than cleanupbutton. Then you have to choose cleanup systemfiles.


Active Member
Oh yeah. I ran CCleaner and it found 1GB of stuff to delete. Ran disk cleanup as you said and it only found 45MB more to delete, ran Cleanup System files and it found another 200MB or so.
Will see if that fixed it.
(If you don't see any more postings from me it means my SP3 is trashed;).


Active Member
Well, Windows 10 is trashed. It wont boot to it. When I select it from the boot menu it reboots (as it should) but hangs on the black screen with backlight and keyboard lights on. I let it sit for about 15 minutes and nothing. At least now that I set Win8 to be the default OS, when I force a power off and re-boot in Windows 8, shows me the boot menu and as long as I pick WIn8 it loads.


New Member
Whoops, I forgot to login overnight and found a whole stack of posts to reply to! Yes, my firmware updates are up to date. And no, Hyper-V isn't activated.

I will try re-installing the display driver and cleaning up the C drive, thanks! The only thing that makes me slightly skeptical is that it's an intermittent problem and had never caused any issues before two weeks ago...


Active Member
I had the same issue this morning. First time ever.

I did a system cleanup, and I had 1.01 gigs of stuff to remove.

The windows update cleanup took forever (more than 1 hour) and my SP3 went verrry hot. Oh yeah baby, very hot.

Eventually, the cleanup ended and I restarted my tablet a few times, just to check. Since then, so far so good.

PS: I still have a lot of questions about the heat and the proximity of the LCD panel (+ the glue of the front glass panel).