What's new

Solved Possible digitizer failure?

Really unusual thing happened today, all of a sudden the pen doesn't register in a strip about 1/4" wide down the left side of the screen (in landscape, top of the screen in portrait). The little "dot" when you hover literally stops dead about 1/4" from the edge, and it basically just ignores that section of the screen. Finger touches in that strip work just fine, it only seems to be the pen that's affected. I have cold rebooted the machine, tried calibrating the pen (can't do it, as it can't reach the left side "crosses" to tap and calibrate.

Have I suffered some kind of digitizer failure? I don't use the pen a lot but it's worked fine for the last several months I've had the computer.

Luckily I have MS Complete so I can get a replacement if necessary but I'll be honest, I went through 4 machines to get this one in the beginning and it would really suck to enter that lottery again. :(

It's an 512GB i7 version.

Any help or suggestions from anyone else who's experienced this would be great.



Well-Known Member
It does sound like a digitizer issue. And by the way, the digitizer, and touch, are 2 different systems and layers, so it makes sense that your pen might not work in a certain area but touch does.

You are not unique in this problems, others here have experienced them as well.

Since you said that a reboot didn't fix it, I personally would consider getting it replaced. This is definitely a hardware defect, so your original warranty would have covered it anyways.


The problem got stranger, where in the bottom left corner of the screen the pen hover dot would suddenly shoot off the right side of the screen. However, clearing the calibration seems to have resolved the issue. No idea why the calibration data became corrupted in the first place however.


Super Moderator
Staff member
Good to hear that clearing the calibration resolved the issue, another one for the bag of tricks.
I suppose a Refresh/Reset would as well be more specific fixes are always better.
Did this problem start right after a System/Windows Update by chance?


I don't use the machine daily so it's hard to say if it was triggered by an update. I did notice that the pen cut out me (wouldn't register the dot or any clicks until I pulled the battery and reset the pen), right before I then noticed the digitizer weirdness.