What's new

Solved powercfg Battery Report missing Usage history, etc

OP
P

Paul Chapman

Member
Same issue here - after full reset there is a first entry 1 day ahead of the refresh date ! somehow it went into the future then back again, and now, no estimate or detailed info at the end of the report in the last 3 sections.

What an annoying bug !

Sven, it took about three days before I had history show up, after the firmware update. I am wondering if it is more than three days past the date the system reset to initially (1 day past the date of the refresh in your case) whether the stats will start showing.
 
OP
P

Paul Chapman

Member
Yes, however, in my case, the date was automatically set to 2062 by the Refresh, and consequently fouled my Battery Report up. Changing it to the correct year, 2014, did not fix it.
Sven, once you restored the system image, it is possible that the system image, if it was the one that came with the surface has had some firmware updates since. You could try checking for updates, and see if there is a firmware one amongst them that you haven't installed yet. Settings--Change PC Settings--Update and recovery--Windows Update--Check now. Worth a try.
 
OP
P

Paul Chapman

Member
Same issue here - after full reset there is a first entry 1 day ahead of the refresh date ! somehow it went into the future then back again, and now, no estimate or detailed info at the end of the report in the last 3 sections.

What an annoying bug !

Microsoft released a firmware update for the SP3 this morning - dated 28 October 2014. For all those with this issue currently, try installing the update (it should auto install if you have that set in Updates). Then run your battery report. See if everything has zeroed out again. If it has, wait a few days, and see if the Usage History repopulate with current data.
 

Members online

Top