What's new

HowTo SD-Card: Add Content to Library; use as primary destination ...

bertopl

Active Member
I think I remember reading somewhere that pictures won't show up from the SD card in your Pictures library if the folder name is "Pictures." Renaming the folder to "Photos" works on mine. not sure if that's the problem you're having.

-- berto
 

borka105

New Member
I changed it to Photos and it didn't do anything.

The Photos app is only sourcing pictures from the "My Pictures" directory regardless of the fact that within the Pictures library it shows all the pictures from my SD card. The Photos App is ignoring everything I have under c:\users\bsnit00\sd\photos and only sourcing from c:\users\bsnit00\My Pictures

I tried to rebuild the index, but maybe this is where I am doing something wrong. Whenever I try to rebuild, all I see is the addition of a "Search" folder pop-up in the library, but nothing else changes
 

borka105

New Member
Hey Arnold-

I've done it so many times and many different ways that I am not even sure what to show you within the "Index Settings" tab. I've now refesed my Surface so it is back to it orginal setting.

By default, the current location is "C:\ProgramData\Microsoft

I've change it to the following new locations- C:\Users/bsnit000\Pictures (I know this is the folder that the Photo app is referencing, but this is not the folder where my SD card "Pictures" foler is located) so then I tried C:\Users/bsnit000\SD, and then C:\Users/bsnit000\SD\Pictures.

And then, I changed the folder from "Pictures" to "My Pictures" and thne to "Photos".

So I've run this now many times to try to figure out how to correctly do it.

Here is an example:

surface.JPG

I then click "Rebuild"

Now should i be checking anything above under "File Settings"?

Thanks
 

J515OP

Super Moderator
FYI borka, you can press the capacative Windows button on the bezel and the Vol - button at the same time to take a screen shot. The screen dims and then the image is saved in Pictures>Screenshots.
 

borka105

New Member
Since I am sure I was doing it wrong initially (I never looked at the screen you posted), I did a re-install of windows to clear anything I may have done incorrectly.. Attached are images of what it looks like by default. Can you please tell me what I need to do in order for it to index properly to update when I add new pictures/remove, etc? My apologies if this is mentioned somewhere else, but none of the guides that I still online provide a walkthrough for indexing.

What's missing in this screenshot would be the SD card drive and subsequent folders: Pictures, Music, Videos

Screenshot (6).png

Screenshot (7).png

Thanks
 

vandeetz

New Member
Are people still getting the videos from the SD card into the Videos app in Windows RT?

I did this once with about 5-6 videos and everything worked great (other than telling me some of the movies were 0 minutes in length) So this weekend I decided to eject the SD and put more movies in. when I did this the old movies stayed in there, the videos app did not re-sync with the library. With the backdoor work around I can see all my videos in the library, but the app no longer sees any of them. I've tried re-doing everything from scratch, but I can't seem to get it to work.

did one of the many updates that have been coming through recently break the ability for this hack to work? MS needs to just allow for removable storage to populate the library for the tablets. I have a 64GB RT, but I'd rather store al my media on the SD. This would make this tablet so much more usable.

any help would be appreciated, let me know if you need me to pass along some info to get this working.
just seems odd that I can see the videos in the library but the app doesn't. I have a ton of videos and need to be able to pull the SD card and add/subtract movies to change it up (not all my movies can fit on a single 64GB card). seems odd it worked once but not again.
 

ArnoldC

New Member
If you used the mounted volumes method, it should work even after an eject, unless the GUID has changed.

You can compare the current GUID, by running this on the command line

mountvol D: /L

You will get something like this-

\\?\Volume{f87a65f5-43f1-11e2-90f6-6045bd6af11b}

copy that string and paste it into your mountvol command as follows:

mountvol C:\Data \\?\Volume{f87a65f5-43f1-11e2-90f6-6045bd6af11b}

Assuming that Data is the empty directory you are mounting it to, if not, just change it to whatever you were previously using.

If you used the link method, it will be broken, so use mounted volumes, and then re-index.
 
Last edited:
Search tags for this page
add sd card to library
add sd card to surface
adding sd card to surface
how to add sd card to surface

microsoft surface sd card

surface add sd card to library

surface sd card

surface sd card libraries
surface sd card library
using sd card with surface

Members online

No members online now.
Top