What's new

SL3 - Unable to boot from any Microsoft keys - Linux keys work fine


New Member
Surface Laptop 3 - Secure boot disabled - USB set to only boot option.

I tried all 4 available recovery images and regular Windows 10 OEM GPT UEFI boot key - they all have the attached error.

I can boot Blancco, Acronis and Ubuntu (all linux based) with no problems.

I also tried install windows on another laptop and then take image with acronis then restore to the surface laptop 3. The restore went ok but same message on reboot.

It doesn't look good for Microsoft product when all you can boot is linux :) lol

Any more ideas are welcome - otherwise that would certainly be a hardware problem.


  • 20230508_120056_resized.jpg
    671.8 KB · Views: 62


New Member
what did you do to the boot configuration/keys to boot linux?
I didn't really do anything.

I made a USB key with Rufus using Ubuntu 22.04.2 ISO image. When I hold volume down (F3) the surface laptop booted from the key and installed with no problems. After installing it does show Ubuntu in the boot device order.

I think I installed it with secure boot disabled. After I enabled secure boot for Microsoft & 3rd party CA key configuration and it's working fine with no error messages.

I'm not sure if that's normal behaviour but I do know I tried everything to load windows but it wouldn't work at all and I've done lots of these before with no problem. Very strange!


  • 20230510_111820_resized.jpg
    125 KB · Views: 22