What's new

SP2 not functioning like a real computer

WhySoSerious

New Member
I'm trying to pay an electric bill by going to CoServ.com

When I'm on my regular PC running Windows 8.1 and log into the website, I click on "Make Payment" and a payment window opens up to continue the process to make a payment.

When I'm on my SP2 in either Metro or Desktop mode, I log into the website, I click on "Make Payment", but no payment window pops up to continue.

Yes, I have enabled popups to open on the SP2.
Yes, I have the latest software.
Yes, I have java

Very odd. Any ideas why the SP2 is not acting like a standard computer does? The primary reason for purchasing the SP2 was to get this exact functionality (full PC ability) that an iPad can not deliver (for the record, you can't use this website for payment on an iPad either).
 

jnjroach

Administrator
Staff member
Make sure you are viewing the site at 100% and not the default 150% that the Pro uses, it can cause the behavior you are describing.
 

Dim-Ize

Active Member
I think this may be a Java issue or an IE 11.xx issue. I have a similar challenge while attempting to run my run EPAY (expense reports) or Cisco's WebEx with IE 11.xx as they aren't supported. So, I have to use Chrome for my WebEx and expense report approval for my team. Both of these products are supported with earlier builds of IE but I just use Chrome for those to business needs.

In that regard, the SP2 IS like a real computer in that I can run multiple different browsers.
 

LuckyL

Member
I believe that this is rather IE 11 than the fact you are using a SP2 so it's likely that you will see that on any system running 8.1.

Try to add the site to the compatibility view settings, for me that usually does the trick. Failing that, you can try an alternative browser.
 

Renigami

New Member
The browser maybe at fault. There is a reason why I still have Opera on my Surface Pro 2. It gives me that slight contingency, should (most of the time, working) Modern/Desktop IE does not behave.
 

kozak79

Active Member
I've had issues with IE. I use chrome now and have no problems. If you disable DPI Scaling for chrome, but then in settings set the zoom to 150%, it behaves like it's at 150 scaling without blurring, crystal clear. Have had no issues with any websites since.
 
Search tags for this page

trying to pay coserv bill on an ipad

Members online

No members online now.
Top