What's new

SP3 - Not 'Sleeping'As It Should...


Active Member
Hi again...

So, I Googled 'SP3 not staying asleep' and got back a pretty spot-on top hit of what is ocurring with mine. The link to it is here:


...and an excerpt is here:

"If you put the Surface Pro 3 or 2 to "sleep" and close the cover it will wake up right away. Regardless of windows wake settings! This happens anytime a keyboard button or input on the trackpad is detected. This also happens with external mice and keyboard. There is NO WAY to disable this. You can goto the advanced hardware wake features on the devices and disable it and it won't make a difference.

So right now ALL Surface Pro 3 users have this issue. This is actually also an issue on Surface Pro 2 that they never fixed! I have both a 2 and 3... So yesterday I called Microsoft to report the issue and of course the girl who answered had no idea it was affecting all S2s and S3s.

She put me on hold and tried at least 2 S3's that they have there in the callcenter for troubleshooting and she was very surprised to see the issue was happening there too LOL!

This is a BIOS issue for sure...the problem is there is no keyboard / mouse wake option in the BIOS. And there are NO WINDOWS SETTINGS that will fix the issue. Its straight hardware... MSOFT needs a major firmware fix....

Not holding my breathe."

So, has there been a fix for this as of yet? This post was submitted over 4 months ago, and I see my SP3 with the same issue. Sometimes the screen turns back on a second or two after closing the type cover. It's really ridiculous.

I have implemented the Hibernation hack via the Group Policy Editor, but I dont really enjoy having to wait until (in essence) the comp boots up again...

Any solution??


Super Moderator
Staff member
All i can say is i don't agree. I put it to sleep, i close my keyboard, it stays asleep..


Staff member
That post is 4 months old.... there were some issues with some devices that had issues with the Keyboard Filter Driver, but those from my understanding have been fixed via the Firmware Updates. I haven't had a "Hot Bag" incident on Windows 8.x in months...


Active Member
I have a SP3 i5 256. Have minimal apps and progs installed.

My power config is set to go on auto sleep after 10 mins, plugged in or on battery.
Not sure what you mean when you ask 'what SW did I install?'.

I was having such an issue with this that I went into the Group Policy Editor and enabled hibernation mode. I also changed it so that pressing the power button puts it into hibernation instead of sleep.

I did that last night. To my astonishment, as I left the office, I pressed the power button and put it in hibernation mode, and about 2 hours later, I take it out of my leather sleeve, and its piping hot, and ON!! Unreal, really.

I did this because the SP3 would constantly come out of sleep. Why would lightly swiping the mousepad be a trigger to wake it?? That seems a bit ridiculous. The only thing I want waking this device is a physical PRESS of the power button.

If anyone can help me achieve this goal, I would be most appreciative! Help!


Active Member
Certain programs can prevent the unit to go to sleep, or can wake it up.

Do you have all the FWs updated to the latest?
I mean, to me, that seems a bit ridiculous. The master setting of the machine should always supercede the individual app/program settings.

I think I found my own ' somewhat' solution to this issue.

I set the GPE to 'always go to sleep when closing lid', and that seems to work better than pressing the sleep/power button.