What's new

Solved Sp3 won't connect to WiFi but will connect through Ethernet.

James. Bundy

New Member
Hello,
My surface pro 3 won't connect to the WiFi. It says limited access and when I attempt to connect to the internet it says it has been secured but there is no internet. I have tried to update the Wifi driver, uninstalling the driver and re-installing, but that hasn't helped. Everyone else on our network are fine and I can connect through another person's internet.

Our internet modem is a D-link viper and I am running windows 10. I have updated my surface to the latest update. I am confused and I don't know what to do.

Please help me.
 

toaf

Member
i remember on my sp2 I had that issue..im trying to think of what fixed it for me. it was some odd check box that made it all good ill go look

might have been a SSID or FIPS setting... its been along time. hopefully those or the ip6 thing helps

I'm guessing it connects to your cell phones hotspot? if it does try trouble shooting from that point.

good luck
 
Last edited:
OP
J

James. Bundy

New Member
Sorry,
I woke up this morning and checked it. It now doesn't work again. I went into the inernet settings and Ipv6 settings were how I left it. ToT.
 

sharpuser

Super Moderator
Staff member
Aha.

There is an incompatibility with Malwarebytes. Microsoft and MB have yet to work out this conflict. This problem cropped up a few weeks ago with Defender Definition files. Basically, Windows 10 recognizes Malwarebytes as hostile. o_O The IPv6 change threw MB off for a short time.

Search for Add or Remove Programs with Cortana, and remove Malwarebytes for now.

Let us know.
 
OP
J

James. Bundy

New Member
Wow, It Worked!
Thank you for helping me!
I am now free from the tangle of wires that trapped my computer. Yay!
 

Members online

No members online now.
Top