What's new

Solved Surface Book Pen - eraser clicks but no writing

MattS

New Member
Got an issue where my surface pen can open one-note, etc with the eraser button, but I am not able to use the pen to write.

When I first powered on the device, my pen was in my suitcase and I skipped the first setup/pen pair process. Not sure if that is the core of my issue, but figured I would mention it.

I've tried the following:
Surface Book Update
BT Re-pair pen
uninstall/reinstall driver

Thanks in advance,
Matt
 
OP
MattS

MattS

New Member
Yes, thank you. I went through that prior to posting the question. Nicely written, but didn't solve my issue.
 

sharpuser

Super Moderator
Staff member
Okay, @MattS.

Let's try to get you fixed up.

The writing part (writing or erasing) of the pen does not use Bluetooth. Only the eraser button and the other buttons do. The screen detects the electromagnetic signal of the pen continuously, when the pen is paired - which means it will use power.

Have you replaced the battery? Or checked the battery terminals? Remove the battery, clean the contacts, then replace the battery.
Then do the two-button restart of your Surface Book, to make sure the screen is doing its part. (Cold power down for 20 seconds, then power up with Power and VolumeUp buttons. When you see the Surface logo, release both. Choose Exit on the UEFI menu.)
 

StewartHands

New Member
Same thing has happened to me as well. It was working fine out of the box.....but the writing functionality stopped.

I have tried re-pairing, battery removal, driver uninstall and the cold boot above but still no writing. the pen clicks all work with Cortana integration working fine.

Any ideas? or is it a call to Microsoft for a replacement?

cheers
stew
 

mbrockvet18

New Member
I am having an issue with writing too. I am trying to pair a new pen because I lost my original pen and the new pen will Bluetooth pair but will not write or right click. I have replaced the battery, done the cold restart, uninstalled/reinstalled the drivers and took the pen tip out and replaced it. I do not know what to do now. please help!

Thanks

~ Matt
 
Search tags for this page
microsoft surface pen not erasing
my surface pen does not write but erasor works fine

my surface pen stopped writing

surface book 2 pen not writing

surface book 2 surface pen tip is not working

surface book pen button works but not writing
surface book pen not working

surface book pen not writing

surface pen not writing fix
surface pen not writing on surface book
Top