What's new

Solved surface mouse brings up settings menu by itself

a very strange behavior started about two weeks ago. I can intentionally duplicate, it just happens intermittently and only when using the mouse. Have a SP4 and a surface arc mouse - the grey one. All updates have been installed. It happens only when I'm moving the mouse and it at least seems when I touch the middle "button" to possibly scroll. All of a sudden, the setting screen opens for no explainable reason. Looked at all the mouse settings, just clueless as what else I can try. Appreciate any thoughts


Staff member
Hello, @larryg-aia ,

If you are certain that your mouse settings for the middle mouse button still are set to "Scroll", and your battery is fine, then your rodent probably needs a little cleaning. Check for / blow out any debris around that button.

Let us know.


well the compressed air didn't work. But I notice that on the left side of the left button in the thin space between the button and the mouse body there was a thin piece of black plastic starting to stick out. I brought it into the Microsoft store - I'm one of the lucky ones to have one 15 minutes away. They didn't even ask for my name, looked at it and gave me a brand new one. So far no issues. But what service, I was just so surprised and wanted to let all know. Can't was for SP5, I'd order it today site unseen. It just pisses me off that the apple store is always packed and even with the limited amount of stores for MS, they typically empty.....except for the one in NYC which was packed. Guess its true, ignorance is bliss.


Staff member
Glad you got good service.
Glad it was a defect in your particular mouse, not in software, or design.

Marking solved.