What's new

Surface Pro charger not working

Bazza

New Member
I bought my Surface Pro one week ago. Charged it immediately - no problem. Haven't had a lot of time to use it, so the battery only ran low today. Plugged in the charger, turned on power and - nada. No little blue light, no power to the Pro, no action.

I've checked with a multimeter and power is getting from the outlet to the transformer. It's coming in at 248V (I'm in Oz) which is a bit high since the charger range is 100-240V, but our standard supply tolerance is +/- 5%, and it wasn't a problem last week. Anyway, power is getting from the transformer to the connector at 12V, which is right according to the small print on the transformer. For some reason, power is not getting from there to the battery. The connector seems to click into place OK and nothing is obviously loose, missing or dirty.

Has anyone else had this problem and does anyone have any suggestions, or is it back to the store with warranty in hand?

Thanks
And to GreyFox7 who sent me a note about his 7 year old charger still woring: this is the porblme, most appear to work, but some of us have repreated issues whihc suggests it is the SP3 and not the charger. For the record, I have three chargers, and none work except that one manages a flickering light, occasionally.
 

GreyFox7

Super Moderator
Staff member
And to GreyFox7 who sent me a note about his 7 year old charger still woring: this is the porblme, most appear to work, but some of us have repreated issues whihc suggests it is the SP3 and not the charger. For the record, I have three chargers, and none work except that one manages a flickering light, occasionally.
It sounds to me like faulty chargers. Chargers that don't hold up over time. I gave examples to illustrate the point that 3 years out of a charger really isn't that good. Of course I don't yank the cords out of sockets and treat them badly but they really shouldn't just go bad in 3 years.
 

Bazza

New Member
Latest news on SP3 chargers:

I bought a new Microsoft charger at £69 - can charge a phone through its USB but it will not charge the SP3.

Have also bought a charger for £24 from something called KFD through Amazon -works perfectly

I can't believe I'm unique, and the palava to get the computer back to Microsoft in the UK means I am not doing it, for no other reason than I would need to buy another computer while it is gone.

Can someone in Microsoft please try and ansewer the issue.
 

Members online

Top