What's new

Trackpad keeps disappearing....

bangsters

Member
Hey. My SB2 keeps losing the Trackpad/mouse cursor..... at times, the screen leaves a round/circle mark like when you press the screen and stays there, but then the mouse vanishes.... I can power off the screen then power back on and the mouse comes back.... but it's getting annoying as it's happening a lot....

I already tried uninstalling/reinstalling the mouse/trackpad drivers.....anyone else having the same issue??
 

sharpuser

Super Moderator
Staff member
Make sure your connectors between keyboard and screen are clean and free of debris - both ends. Sounds like a poor electrical connection somewhere.
I had this happen to my SB2 15 inch for a few weeks and it drove me crazy enough to do a clean install. Turned out that a tiny metallic sliver was attracted to the magnetic connectors, causing a short. And a very thin thread of vinyl protective skin was also interfering with me connecting all the way snug and tight.
 
OP
B

bangsters

Member
Thanks buddy. So far the issue went away.... i hninstalled photoshop 2019 since I have both 2020 and 2019.... since then no issues... crossing fingers tho

Sent from my SM-N960U using Tapatalk
 
OP
B

bangsters

Member
Spoke too soon. Started doing it again. Doesn't appear to he the connectors.


Sent from my SM-N960U using Tapatalk
 
OP
B

bangsters

Member
Just did a full reinstall, latest updates... still no luck... Only have office 2016 and adobe illustrator/photoshop/creative cloud installed...

i'm at a loss for words on this one.... and it's not even 2 years... got it feb 2018....
 

sharpuser

Super Moderator
Staff member
Must be very annoying. Unlikely to be hardware.

A few questions:

- For troubleshooting, have you enabled the "Show cursor when I press Ctrl key" option, and does the cursor re-appear when you press the Ctrl key?
- Are you using Chrome?
- What happens if you place your SB2 in Tablet mode, then exit Tablet mode. Any change in behavior?
 
OP
B

bangsters

Member
Nope I did not. But I did notice, touch screen also becomes erratic with a bunch of circles showing up, like when you press the screen, but they get stuck there.... the keyboard continues to work though.... pressing power back to sleep then back up, and it comes back... really can't figure it out lol.

Gonna try that troubleshooting. Thanks
 

sharpuser

Super Moderator
Staff member
@bangsters,

Your latest description of the erratic touchscreen may give a clue. Check for these things, no matter how far-fetched they may seem.

1) Loss of the seal between glass and screen: Do you see any battery bulging, or widening of the seam between glass and aluminum of your touchscreen perimeter? Even if there is no bulging, moisture may have entered your computer.

2) Is there any residue of adhesive or cleaning solution or screen protector on your screen?

3) Do you notice excess heat from the screen?

4) Does it happen even when plugged in to the charger?

4) Could your SB2 be suffering from electromagnetic interference? This can come from "nodes" of the confluence of several factors, like microwave communications/towers in your area, yes, even broken microwave ovens, concentrated routers such as in apartment or dormitory environments, poor electrical grounding of your power source or leakage from fluorescent lights, or even extreme PC gaming rigs (a tower/power PC) very nearby. To eliminate this as an option, simply take your SB2 to another location, and see if the same problem, or as sever a problem, occurs.

This sounds crazy, I am certain, but we are trying to get you some relief!
 
OP
B

bangsters

Member
Thanks!! It happenes randonly, sonetimes days without issue and then some days every few mins... very random lol.

No magmetic interference as I don't take it near the kitchen or any appliance that could cause such. I don't see any gaps or seals loose... and no excessive heat.

I do agree it does not look like a hw issue, but then I already did a full reinstall with latest version.

Could it be adobe? Only stuff I have in here are adobe apps, office apps, and firefox. Didn't install anything else.

Oh and the issue occurs evem while plugged in. Battery icon is set to the middle between max savings and performance. Will try to set it to the right most.

Sent from my SM-N960U using Tapatalk
 

sharpuser

Super Moderator
Staff member
Regarding your second point, interference is bigger than the rooms of your house. Towers, power lines, etc. could be the problem. Your touchscreen is essentially a special antenna particularly sensitive to changing electromagnetic fields. Just to be sure, try it from a different venue.

I doubt it is Adobe. I use Creative Cloud myself.

Do a clean install. Everything.
 
OP
B

bangsters

Member
Sorry for lack of reply, went cross country drive for the holidays.

So far the issue has barely presented itself after the reinstall and updates.

I removed insider as well when i reinstalled.

Btw, forum is barely usable on mobile. There is an ad at the bottom that stays there occupying half the screen. If I start typing the text box for response is not visible.
 
Top