What's new

Try this if you have Limited Connectivity issues

olimjj

Active Member
I replaced my router this weekend and ran into this problem. After many hours of trouble shooting, I've come to the conclusion that the Marvell driver has issues with N networks. The only way I've been able to get reliable connections is to switch my network to G.

Assuming you have a dual band router, do you have issues with both bands? Not sure if it is related but I use 5GHz exclusively and have not encountered any problems.
 

Ruffles

Active Member
I do have a dual band router and when I use the N band on either 2.4 or 5 GHz, I have issues. I've switched it to G with mixed mode TKIP + AES and it seems to be working fine. The puzzling part is that other N networks that I've been on don't seem to have this problem.
 

olimjj

Active Member
I do have a dual band router and when I use the N band on either 2.4 or 5 GHz, I have issues. I've switched it to G with mixed mode TKIP + AES and it seems to be working fine. The puzzling part is that other N networks that I've been on don't seem to have this problem.

Puzzling indeed. The sucker bet assumption would suggest router manufacturers, but that is extremely unlikely if not totally absurd. Have you checked with "inSSIDer" with regard to signal strength, Security Mode, etc. Perhaps that might focus on a differential between your network and the others you have successfully connected to. My previous queries are not meant to suggest that you have not carried out an intensive and obvious trouble shoot, but rather to gain some additional details.
 

Ruffles

Active Member
Yeah, I spent the whole weekend working on it with inSSIDer. I replaced all my networking equipment because it was 15 years old. I bought a nice linksys (EA4500) and hooked it up. All was well until that night when the connection started dropping. I went to my office to reboot it and it was so hot, it almost burnt my hands (I know people say stuff like that but a really could not place my hand on the bottom of the router). After multiple reboots and resets, the connection was always flaky so I returned it for a netgear N900. This one doesn't have the heat problem and all my other devices connected just fine but the Surface would start with a fast connection and it would slow down until nothing worked and I got the limited connection error.

I tried all combinations of encryption and channel etc. I tried reverting to the original Marvell driver but nothing seemed to work. For now, I've go the 2.4 band set up for G and the 5 band for N. I'll use it on the G and when a fix is released, switch over to the N.
 

DOTTAT

New Member
Think i'll chime in with my experiences since this started happening to me now also. I currently have a linksys WRT610n as my wan router with an ASUS rt66u serving up the 2.4ghz and 5.0 ghz radios. The DHCP is disabled on the asus and it's merely acting as my radios for my home network. I get the limited connectivity crap on either 2.4 or 5ghz. If i switch from one to the other, i can ping the main router's IP for approx 10 seconds afterwhich all packets drop and i see limited connectivity. This happens with the old and new driver.

I don't think I had the issue when i was solely on the asus router. I recently had to add the second router (linksys) because it supports HNAP protocol which my home security system requires. I'm pretty sure it has something to do with network layer discovery and have yet to try disabling that to see things improve. That's my next step.

Are others with this problem using a single router or more than one access point (router, repeater etc) ???

-edit-... also wanted to add that when i take my SP to work with me it works fine on a WNR3500v2 that is running DD-WRT. This is running wireless N and currently only using 20mhz wide carrier (single stream). It works.. so someone who rolled back to N may want to try setting their router to 20mhz first and see if you can get away with single stream N without issues.
 
Last edited:

Ruffles

Active Member
I'm using a Hawking Technologies repeater but I tried removing it to isolate the problem but it still occurs.
 

BillJ

Active Member
Ever since the mid-March update I have been experiencing the episodic wifi connectivity problem, and I thought it was better with adjustment of the Marvell driver properties, but sadly, the problem is back again. I notice it also on my Zenbook that is running Windows 8, after the update as well. Could this be a problem inherent to Win8, and not necessarily due to wifi network hardware?
 

N.G.

Member
Disabled Selective Suspend. Don't seem to be losing WiFi, which was happening frequently. Don't know if an update changed something also as I was away from home for 4 days after disabling SS. Still, it is MUCH less irritating. Maybe I won't go buy a new ASUS AC router to replace my Cisco 4200.
 

revmike

Active Member
This is one more reason that I'm waiting awhile. I had the same issue with a viliv 70ex tablet which had an atheros wifi card. It was so bad and annoying that I used a wifi dongle without any further limited connection issues.
 
Last edited:

bertopl

Active Member
Disabled Selective Suspend. Don't seem to be losing WiFi, which was happening frequently. Don't know if an update changed something also as I was away from home for 4 days after disabling SS. Still, it is MUCH less irritating. Maybe I won't go buy a new ASUS AC router to replace my Cisco 4200.

this was my experience as well. I was getting limited connectivity once in a blue moon when the surface was new. was getting it almost every day after the march update but turned off selective suspend per this forum and haven't had it since. are the people who are still experiencing this have selective suspend disabled?
 

Ruffles

Active Member
When I switch off the selective suspend, I can't wake the surface up from sleep. I have to reboot it each time :(. It's an interesting problem though. For home, I've just switched to the G band. At work and other places, it seems to connect to N networks but sometimes slowly.
 

Members online

No members online now.
Top