What's new

Try this if you have Limited Connectivity issues

BillJ

Active Member
I finally got fed up with having to disconnect and reconnect to wifi, so I took the following steps:
a) disabled the Marvell driver
b) installed a Netgear usb wireless adapter

Works perfectly. I am bummed that the USB is taken up by this ugly gizmo, but at least things are functional again. I think this isolates the problem to the Marvell driver, but I could be wrong.
 

tonyz3

New Member
I finally got fed up with having to disconnect and reconnect to wifi, so I took the following steps:
a) disabled the Marvell driver
b) installed a Netgear usb wireless adapter

Works perfectly. I am bummed that the USB is taken up by this ugly gizmo, but at least things are functional again. I think this isolates the problem to the Marvell driver, but I could be wrong.
correct if i am wrong but i dont think you need to disable the marvel driver. just plugging in the netgear will give you a wifi 2 option listed in networks and you can connect to that one and disconnect from the wifi 1 when the netgear is plugged in.
 

Omni

Active Member
Is it just the pro having these issues now? I've had my RT for months and only had a limited connection once. That turned out to be a repeater but that's working now thanks to one of the updates. I connect to a lot of WiFi networks and never had problems other than that.
 

J515OP

Super Moderator
Yes, it is mainly just the Pro. If you have connection issues on the RT the odds are that it is something in the setup and not the device itself.
 

haleme

New Member
I have Selective Suspend disabled but am still getting the limited connectivity issue. I can reproduce the situation by plugging in a USB 3.0 hub. I am still trying to determine if the hub is defective or something else is at play.
 

haleme

New Member
Did a little more "research" today. Even without the USB hub, I can still get limited connectivity. It seems to be more pronounced when switch from the desktop to a Metro app. I am going to roll back the Marvell 350N Wifi driver because Patch Tuesday is when this started to be a problem (same day I got the new USB hub).
 

haleme

New Member
OK, I think I have resolved this issue on my SP. The Bing app seemed to be the culprit. I noticed that Wifi would work just fine until I opened the Bing app to do a search. Then, the results would not open IE and the connection would drop, while not actually showing disconnected or limited. Waiting for the connection to reestablish or switching airplane mode off and back on would get me back online. Uninstalling the Bing app, restating and reinstalling the app appears to have fixed my Wifi issues. So far, I have not experienced any issues with connectivity since yesterday morning.
 

spectre51

Member
I'll chime in with my wifi issues I have noticed on my Surface Pro. I have a Verizon Fios wireless router in my office upstairs. In the mater bedroom down the hall I have an Apple Airport Extreme (single radio) plugged in via Ethernet acting as a wireless range extender, downstairs in the kitchen area I have a Apple Airport Express access point, setup just the same as the airport extreme. Each router is using the same SSID 2.4ghz b/g/n mode.

I had it setup like this so if you go to a different area of the house you would be on the same SSID yet connect to the stronger wifi access point. This worked fine with my iPad, wife's iPhone, my android and windows phone as well as MacBook Pro. The Surface Pro on the other hand seemed to only connect to either of the Airport devices and even if I was sitting right next to the Verizon router it would not connect to it. (was checking mac addresses to verify which router it was connected to). Even if I deleted the wireless network on the surface pro and reconnected it would still only go to the airports.

It worked okay for the most part yet I would experience times where the SP would change to limited connectivity while I was in my office. I would have to diagnose the connection issues in network and sharing center where it would fix it then I could use wifi again, or I would have to reset the airport extreme, sometimes both. This went on for a little while till I got fed up with it and ended up changing the SSID of the Verizon router. Now it connects to it just fine and if I go into the bedroom I just change the network its connected to manually.

Unfortunately with this setup I now have to change all the devices wifi networks manually when I go to different parts of the house. I am gonna do more testing to see now that I have the networks separate if there is any issues with it connecting to the airport extreme since that's the only one I have noticed an issue with. I have Selective suspend still enabled.
 

Members online

Top