What's new

Wifi Problem not caused by adapter

bennywiggs

New Member
One or two days after the last big update I received on my Surface Pro 3, my wifi stopped working. Interestingly, it does not seem to be the Marvell Wifi adapter that is causing the problems. I have tried connecting to my home network and my school network. This is what I have come up with:

1. The Wifi adapter seems to connect to the router, but I see messages like "No Internet Access, Open" or "No Internet Access, Secure" (depending on which network I am attempting).

2. I have tried uninstalling and reinstalling the Marvell device. That did not work.

3. I disabled the Marvell device, and I installed a Linksys USB Wireless Network Adapter. It runs into the same problem on every network I try.

4. I put the Linksys adapter in my desktop, and it connects to the internet just fine.

5. All of my other devices (phones, PS4) have no problem connecting to these networks.

I feel like I have ruled out the network/modem/router. I have also ruled out the wireless adapter because it happens on the surface pro no matter which adapter I use. What else could it be?! Any suggestions?

Oh. One more thing. If I open Edge, Edge locks up. It does not show the standard white screen that says it is not connected. it is just black, and I cannot exit out of it without going through the task manager. Further, I hear the fan really speed up whether or not I have Edge open.
 

Members online

Top