What's new

Bluetooth connection issues

OP
K

Kris

Active Member
Maybe it works different with bluetooth speakers or maybe you are very lucky. I have read tons of cases where people are having the same issue that I am having, it also seems to happen to some peoples bluetooth keyboards and mice. I am on my 3rd SP3, returned the first one for this issue and second for defective pen but all 3 had the same issue with bluetooth headsets. I love my SP3 and don't want to try and replace it, not even sure there is anything out there like it to replace it with, so now I am looking for work a rounds until Microsoft fixes the issue.
 

jnjroach

Administrator
Staff member
I believe this issue is much more prevalent for those using 2.4GHz Wireless and Bluetooth. Using 5GHz Wireless has no contention with the Bluetooth Radio...
 
OP
K

Kris

Active Member
I am running on 5GHz, I do have a 2.4GHz running for some older devices in the house though.
 

jnjroach

Administrator
Staff member
I am running on 5GHz, I do have a 2.4GHz running for some older devices in the house though.
Another option is to see if your Bluetooth Device has its own Firmware Upgrade, I use a Voyager Pro v2 and a Jambox Bluetooth Speaker without problems on my SP3. I also use other Bluetooth peripherals (keyboard, mouse and smartcard reader)....
 
OP
K

Kris

Active Member
firmware updated... you must be real lucky. what SP3 are you using. I am using the I5 256gb
 

jnjroach

Administrator
Staff member
I5/256

Bluetooth Devices:
  • Mini Jambox
  • Plantronics Voyager Pro v2 Headset
  • Wedge Mouse Surface Edition
  • Wedge Keyboard
  • Bluetooth Smartcard Reader (DOD Approved)
 
OP
K

Kris

Active Member
damn now I am just jealous....
I tried with Plantronics Voyager Legend, Plantronics Voyager Edge and the Big Jambox... All 3 would cycle through disconnect/connect every few seconds unless I was constantly listening to music or watching a video, as soon as one stopped it would go through the connection cycle over and over...
 
Last edited:
OP
K

Kris

Active Member
No it disconnects from the SP3 and announces that to you. "PC disconnected" then a couple seconds later "PC connected". I am going to disable my 2.4GHz side of my router and update my SP3 to the 8/19 firmware and see if that was the issue...
 
OP
K

Kris

Active Member
Still getting disconnects but not constant like I was getting. Was every other second now its like 4-7 minutes of no use and it disconnects but does not try to reconnect. I might be able to live with this...
 

SurfaceProJoe

New Member
I'm having a similar issue with trying to send files via bluetooth to my phone (iPhone 5). When I'm in settings it says that they're paired but when I go to send a file it says:
Windows was unable to transfer some files
Make sure your bluetooth wireless connection is working properly and your computer is within range of the bluetooth device or bluetooth enabled computer you are trying to transfer files with​
Has anyone encountered this?
 

Members online

Top