What's new

Boot Up Screen Flashes White

Status
Not open for further replies.

p3ntyne

New Member
I just noticed that when I boot up my Surface, the entitre screen will flash white, very quickly right before and after the boot logo appears. It boots up fine and isn't really a big deal but I'm just wondering whether or not anyone else has experienced this.

Thanks
 

Grumpy2

Member
My SP3 i7/256 has been doing the same since the last firmware update 19/5/2015 which I installed on 24/5/2015. I get two white flashes every time I wake up the device or switch it on etc. Was fine before the update. Looks like Microsoft has stuffed something up here.
 
OP
P

p3ntyne

New Member
My SP3 i7/256 has been doing the same since the last firmware update 19/5/2015 which I installed on 24/5/2015. I get two white flashes every time I wake up the device or switch it on etc. Was fine before the update. Looks like Microsoft has stuffed something up here.

It's good to know that I'm not the only one with the issue. Although, I do not have the issue when waking from sleep, only when booting.

Interestingly, I had a look at someone's i5/128 and it didn't have the issue. I have the i7/512 so perhaps it's only an issue with the i7 models.
 

Telstar1948

Active Member
...mine too i5/8GB/256, since the last update. Also, mine is running warmer and the fan is coming on more frequently since the last update.
 

samali

New Member
Hello,
I have the same issue on my device and for sure it is recent after some update.
However I relay would appreciate which one have caused that. I don't like it at all. I'll try to remove one by one the latest updates I might find the one causing that issue.
Anyway thanks if you find something before.
 

samali

New Member
In fact when I am saying issue I didn't mean this affects the operating system or other software. I only don't like thing that appears unusual.
I started uninstalling all May windows upgrade but didn't do any good. The phenomena is still there.
 
This is caused by the latest firmware update. There is no software to uninstall to fix this. We will have to wait until MS releases a fix in Firmware.

Firmware updates in the SP tend to be overlooked since they just install and work from the automated windows update process.
 

lords20

New Member
Yes the firmware did this. But it is the video drivers. When I installed the Intel 10.18.14.4206 4/29/2015 video driver it has stop flashing the white screen. I found it here http://www.surfaceforums.net/threads/windows-10-preview-on-surface-pro-3.11828/page-240 the last post.

Here is the intel download link; https://downloadcenter.intel.com/download/24937
This beta driver is released to resolve issues some users are reporting regarding a "flickering display" issue on some Intel® NUC products

It worked for me but, use it at your own risk it's not my fault if your sp3 is bricked or any problems with it!!!
 
Status
Not open for further replies.

Staff online

Members online

Top