What's new

Boot Up Screen Flashes White

Status
Not open for further replies.

samali

New Member
Hi Lords20,
I havebtried to install the driver above but couldn't complete. It says not dedicated for this device.
can you you please let me know the exact one to dl for my sp3 8gb 256gb.
thanks
 

Randy31416

New Member
I too installed the latest Intel drivers (153621) and, although they work well, they do not stop these new white flashes during boot.
 

samali

New Member
By the way, any one tried to reinitiate the sp3 from scratch. According to my contact wit MS Services they recommend me to do that but I can't do it right now for personal reason. However later on if no solution is found I'll be obliged to do it.
 

xbliss

Member
I just noticed that when I boot up my Surface, the entitre screen will flash white, very quickly right before and after the boot logo appears. It boots up fine and isn't really a big deal but I'm just wondering whether or not anyone else has experienced this.

Thanks
Welcome to the club. Join the survey.
http://www.surfaceforums.net/threads/whos-experiencing-white-flashes-during-startup-restart.15733

Yes the firmware did this. But it is the video drivers. When I installed the Intel 10.18.14.4206 4/29/2015 video driver it has stop flashing the white screen. I found it here http://www.surfaceforums.net/threads/windows-10-preview-on-surface-pro-3.11828/page-240 the last post.

Here is the intel download link; https://downloadcenter.intel.com/download/24937
This beta driver is released to resolve issues some users are reporting regarding a "flickering display" issue on some Intel® NUC products

It worked for me but, use it at your own risk it's not my fault if your sp3 is bricked or any problems with it!!!
Was anyone else able to get this to work?

By the way, any one tried to reinitiate the sp3 from scratch. According to my contact wit MS Services they recommend me to do that but I can't do it right now for personal reason. However later on if no solution is found I'll be obliged to do it.
Looks like we might have to go that way later if things dont get fixed.
 

Grumpy2

Member
By the way, any one tried to reinitiate the sp3 from scratch. According to my contact wit MS Services they recommend me to do that but I can't do it right now for personal reason. However later on if no solution is found I'll be obliged to do it.
Yes I have been thinking about doing that but as I am going away shortly I just cannot do it right now. When I get back at the end of the month I might go down that track and see what happens. Come mid September I will have had my SP3 for 12 months and I was going to do a factory reset then and start again. Perhaps I will do it earlier.
 
Status
Not open for further replies.

Members online

Top