What's new

Can't Connect to Internet

Dane

Member
I'm puzzled. I can connect other devices to the internet, so I know its the SP2 that's the issue. It connects to the wireless network, but there is no Internet connection.

The only other odd occurrence is what. Get the message "the connection is limited" when I connect to my network.

I've tried recurring several times, including restarting both the router and the modem.

Any ideas?? Everything worked fine last night, so I can't figure out what happened over night.

Edit - I've also tried connecting to other networks with again the same issue.
 
Last edited:
OP
D

Dane

Member
Yes.

I've since used the restore feature and things seem to be back to normal. Although the signal was lost again once since restoring,, it worked itself out again.
 

Rvacha

Member
I just started having this problem 2 days ago on my SP2. I have latest drivers and firmware (didn't have any install issues). Unlike past bouts of SP limited connection problems this time around there is a new twist - Marvell driver power state failures resulting in 3 BSODs. I just uninstalled the WiFi driver and let it reinstall. We'll see if that works. Strange that this just appeared for no apparent reason
 

Dim-Ize

Active Member
Try disabling Bluetooth (temporarily). Then stop the WiFi. Delete that saved WiFi profile. Then restart WiFi and manually connect (you can check "save profile" during this step for future connects. See if things work that way. Then try re-enabling Bluetooth.
 
Search tags for this page
can't connect to internet with surface 2
cannot access the internet from my surface
cant access internet on surface pro 2
i cant connect my surface to the internet

surface cannot connect to internet

surface cant connect to wifi
surface connects to wireless but no internet
surface pro 3 cant connect to internet
surface pro 3 cant connect to wifi

surface pro unable to connect to internet

Staff online

Members online

Top