What's new

Does anybody else have a hot Surface on the latest firmware?

Mastiff

Member
After the firmware update a few days ago it seems like the fan on my SP7 is running almost all the time, at high speed. And the device is far too hot for the 10-18 % CPU I'm using. It's not even hot, June was a lot hoter here in Norway, so that's not the problem.
 

ScottyS

Active Member
My SP7 just got Surface - Firmware - 14.104.139.0 this morning. Is that the firmware update you got?
My fan has usually been running but not high all the time and the unit wasn't getting too hot. Will have to keep track of this after this firmware update.
 
OP
Mastiff

Mastiff

Member
What's the firmware number hidden under? I thought it was under firmware, UEFI, but the number I have there is 235.3192.768.0. So a different format. Also SP7, i7.
 

ScottyS

Active Member
I'm going by Settings/Update/Update History under Drivers, the only firmware update I've gotten is Surface - Firmware - 14.104.139.0. And my SP7 is running cooler with less fan than before.
MS site says "Improves device reliability during low battery scenarios." but mine's running cooler with the fan on even less than it used to be with 100% battery running it plugged in.
 
OP
Mastiff

Mastiff

Member
I'm an idiot. I wrote SP7, I meant SP6... I found the latest firmware. It says Surface - Firmware 11.8.70.3626.
 
OP
Mastiff

Mastiff

Member
According to this the update is "for Surface Laptop, Laptop 2, Surface Pro, and Pro 6":
 

Turbo4AWD

Active Member
According to this the update is "for Surface Laptop, Laptop 2, Surface Pro, and Pro 6":
SP6 i5....of course no fans. I would have to find an app to check my temps.
 
OP
Mastiff

Mastiff

Member
I don't know if that's even the same firmware since it doesn't have fans, though.
 

Members online

Top