What's new

Factory reset SP3: Install Intel HD Control Center?


New Member
I factory reset my SP3 a few days ago, I would like to install the Intel HD drivers so I can use the control center for scaling games.

I tried installing the latest 4400 drivers from Intel, but using either the .exe or the .zip gives me an incompatible message. I've tried using the device driver to manually install the driver, but roll back does not appear as an option. Trying to install the generic driver over the existing one gives a message that the 'Latest Driver for the device is already installed. This despite the fact that the MS drivers are from March and the Intel drivers from November.

I've tried uninstalling the existing driver completely, but it looks like the surface loads them right back up when it restarts. Any suggestions on how to get the generic driver loaded would be really appreciated, thanks.


New Member
Figured it out, just in case anyone else has the same question:

<link removed per Forum Rules - instructions are available in the forum use search>
Last edited by a moderator: