What's new

Flash No Longer Working on RT After IE11/Flash Updates

Dudeguyy

New Member
Cannot get Flash to work on my RT since last week.

It was working great until an update last Wednesday. Checking the update log, it looks like they patched IE 11 and Flash pretty heavily (KB2938527 & KB2925418, for reference). After that update, Flash isn't operational on MAJOR sites. No ESPN, no MLB.com streaming of game audio, couldn't stream audio of a college team thru their website (Huskers) that I was literally listening to before starting update.

I either get messages stating "playback of this media is not supported' (Husker stream) or that I need to download latest version of Flash to view the media.

YouTube works, but gives me message to update Flash or it won't work.

When clicking update Flash link-- tells me it is integrated into IE already. It is indeed enabled and ActiveX filtering off, which are the only two suggestions Adobe gives for Flash problems on RT.

Any ideas how to remedy this? What a pain in the ***...!
 
Last edited:

kundas1

Well-Known Member
maybe do a restore to the day before the IE11 update? that might fix it...but I find it hard to believe MS would do an update for IE11 with outdated flash version...it could be those pesky and annoying fake flash update pop ups on some websites.
 
OP
D

Dudeguyy

New Member
maybe do a restore to the day before the IE11 update? that might fix it...but I find it hard to believe MS would do an update for IE11 with outdated flash version...it could be those pesky and annoying fake flash update pop ups on some websites.
I could try a restore, but what a crappy workaround.

Am I the only one that has had this problem?

Is there no way remove/reapply the update or uninstall/reinstall IE11?

The frustrations with the little things mount for me with Windows lately... just had to do a clean reinstall of my desktop to get it booting again. There's no easy downgrade from 8.1 Pro to 8.1 outside of clean reinstall apparently :/
 

kundas1

Well-Known Member
apparent your the only one with this prob. Mine works perfectly... or maybe nothing is wrong with your device, its just a false pop up
 

stuntbear13

New Member
You are not the only one with this issue. This affected me, too. By disabling the tracking/Adblock lists in privacy settings flash works fine.
Flash worked with tracking lists on prior to update.
 

kristalsoldier

Well-Known Member
You are not the only one with this issue. This affected me, too. By disabling the tracking/Adblock lists in privacy settings flash works fine.
Flash worked with tracking lists on prior to update.

Yeah...I noticed this problem too! I do wish this kind of stuff had some sort of consistency!
 
OP
D

Dudeguyy

New Member
Thank you StuntBear. That was a very intuitive suggestion. Unfortunately for me, that didn't fix my issue. I disabled tracking and I get the same damn messages about Flash needing updating. I even turned Privacy settings al the way down/accepting all cookies... no dice.

And, just for clarification, this is NOT a false pop-up. This is the legit pop-up that is supposed to appear when I launch MLB.com's audio stream. And I HAVE used this and various other Flash functions like it to work on my Surface in the past, so it's not like the websites themselves are unsupported. They're major sites.

Any other ideas??? I think I'll start a thread on MS support as well and see if I can manage to find one of those tech support bums that isn't clueless.
 

Sepp007

New Member
You are not the only one with this issue. This affected me, too. By disabling the tracking/Adblock lists in privacy settings flash works fine.
Flash worked with tracking lists on prior to update.


Same Problem here on Windows 8.1. CAn not activate Flash Player in add-ons. Both Buttons (enabale, disable) are shown, but not accessible.
Nothing working so far (surfed a lot in Forums)
changing to Chrome now... :(
 
OP
D

Dudeguyy

New Member
Same Problem here on Windows 8.1. CAn not activate Flash Player in add-ons. Both Buttons (enabale, disable) are shown, but not accessible.
Nothing working so far (surfed a lot in Forums)
changing to Chrome now... :(
Is this on a Surface RT or Surface Pro? I would imagine it would make a difference whether you were running 8.1 RT or full blown 8.1.

RT certainly seems to have become the red-headed step child of the Windows OSs as far as receiving updates and support from Windows. In our case, the updates we do get are buggy enough upon release to cause MAJOR headaches.
 
OP
D

Dudeguyy

New Member
Update:

Got Flash working again, temporarily. I had to Refresh my computer last night and this morning, upon charging, everything seems to be working perfectly in IE.

It would appear that hangup was indeed caused by the recent IE/Flash updates that I mentioned in the OP.

I think I'll go ahead and try to apply all the Updates that now need reapplied EXCEPT the IE/Flash ones. I'll see if that works without issue. After that, I may try to apply those updates and see if it was just a bad installation somehow.

Sepp, if you're having the same problem, you may try either using Refresh (which will likely mean you'll have t reapply some personalized settings and wade through some firs time user stuff) or search for "View installed updates." Open that and use it to find the IE/Flash updates and see if you can manually remove them. I have a hunch that may fix your issue.
 
OP
D

Dudeguyy

New Member
Update: Problem solved.

Steps: Refresh, reinstall all windows updates ==> Flash no longer being a whiny b****.

I guess the take home lesson is if you notice something is wonky and think it's due to a particular patch, try to locate the specific update, remove It, and reinstall. If that fails, try Refreshing and just reapplying all updates.

Did you get your problem fixed Sepp?
 

kristalsoldier

Well-Known Member
Ufff...this resetting business is really off-putting! I can understand doing it for major stuff, but to get stuff working because updates broke things is a bit irritating.
 

Members online

Top