What's new

New Sleep Problems with June Update - "Surface" App is the culprit

DL Ford

New Member
Hello everyone,

I'm new here, I was very pleased with the battery drain in sleep since the June update, getting around 3% drain overnight, but now since a week ago I'm back up to right around 20% drain. The Bluetooth hardware will not enter sleep state, in the sleep study under FX Devices > USB Controller > USB Root Hub > Marvell AVASTAR Bluetooth Adapter - Active Time 99%. If I disable Bluetooth the problem goes away, but obviously for a device that comes with a Bluetooth pen this is not a permanent solution. I've tried uninstalling the Bluetooth driver and restarting, turn off connected standby, restart, turn it back on, restart, two button restart, yesterday I disabled and uninstalled the drivers for all of my Bluetooth devices, restart, connected only the surface pen and nothing else, still same problem overnight. I'm at loss, anyone have any insight for me?

Thanks a ton,

DL
SP4 i7 16gb 512gb
 
Last edited:
OP
D

DL Ford

New Member
Update, I may have just figured this out, apparently all I needed to do was ask for help lol!

I remember last week the "Surface" app that lets you customize the pen button asked for permission to connect to the pen or something like that, I was in a hurry so I just clicked yes because it said you could change the setting later, that was about the time the problem started. I went through that app looking for that setting and couldn't find it, so I uninstalled the Surface app. Good news is my button customizations stuck, even better news is in a quick 15 minute sleep, the sleep study shows that Bluetooth did enter a low power state and was only active 2%.

I will run a longer sleep to verify but I think this is probably solved, so a quick PSA - if the Surface app asks to connect to your pen, tell it NO! (At least for the time being).
 
OP
D

DL Ford

New Member
Confirmed solved, after removing the "Surface" app, in the last two hours of sleep, Bluetooth was active 2% of the time.
 

Staff online

Members online

Top