What's new

Solved SP3 Keyboard issues

little ter

New Member
I was recently blessed with an SP3 and it came with the purple keyboard. As a guy I preferred the Dark blue found at Best buy so I bought one. It worked fine for a couple days and then suddenly stopped functioning. The blue keyboard lights up and I can dim the keyboard but nothing else works on it. I can snap the purple one back on and it works just fine. I returned the blue one to best buy and they sent me a new one. It too does not work. When I first attached it, windows installed the device but it will not function. Looking for help with this colorful conundrum.
 

kundas1

Well-Known Member
ok what I suggest you do is remove the drivers for the keyboard and then re-attach the blue one and re-install the drivers and it should be good, I think the purple one is interfering with the blue one, even though they are the same keyboards and everything, they don't play well together... that's what I had to do when I replaced my black one with the blue one like yours
 

kristalsoldier

Well-Known Member
ok what I suggest you do is remove the drivers for the keyboard and then re-attach the blue one and re-install the drivers and it should be good, I think the purple one is interfering with the blue one, even though they are the same keyboards and everything, they don't play well together... that's what I had to do when I replaced my black one with the blue one like yours
Hey...if that is the case, then how is it that when I changed my dark blue KB for a black one (the former was looking really worn out though still perfectly functional), the exchange was seamless? Or, is this like one of those temperamental things?
 

kundas1

Well-Known Member
I can't answer that as I'm not technically knowledgeable enough to say... but I DO know that when I changed KB's it didn't work with a straight swap, I had to uninstall the drivers and reconnect the new KB and reinstall
 

mennogreg

Active Member
I had a worry similar to what you experienced. I found out that sticky keys/filter keys was turned on. Check to see if all those are turned off.
 
OP
L

little ter

New Member
Well, I tried all of the above solutions without success. I finally did a PC Refresh and seems to have solved the problem. I had the blue keyboard attached during the process and it is working just fine now. Thanks to all who took the time to help.
 
ok what I suggest you do is remove the drivers for the keyboard and then re-attach the blue one and re-install the drivers and it should be good, I think the purple one is interfering with the blue one, even though they are the same keyboards and everything, they don't play well together... that's what I had to do when I replaced my black one with the blue one like yours
I was having a problem with my KB that it was attaching but only the back lights were turning on and nothing else was responding. Your method worked for me by uninstalling and reinstalling the drivers. Thank you for your tip.
 
Search tags for this page
i can type password with sp3 keyboard but nothing else
keyboard on sp3 not working
microsft sp3 keyboard not working
sp3 keyboard issues
sp3 keyboard not typing

sp3 keyboard not working

sp3 keyboard problems
sp3 on screen keyboard problems
sp4 keyboard problems
windows 10 tp surface sp3 keyboard issues

Members online

No members online now.
Top