What's new

Strange Chrome Behavior


Active Member
Chrome started misbehaving badly on my SP3 last week. I have the 64-bit v. 39 (I think...don't have the Surface nearby at the moment). The primary window started disappearing after starting up. I have it set as default browser, running in Modern mode, and it starts, shows the red screen for a moment, then disappears, leaving several running processes behind. I've tried restarting, deleting and reinstalling, etc. to no avail. It runs fine in desktop mode.

The new IE is much better than any version that has come before, but Chrome is still my main browser.

Any thoughts or similar behavior?

Edited to add: This is only happening with Chrome, not other MUI apps, though a couple of times I've seen MUI apps (Microsoft Solitaire, for sure) slow almost to a halt and suddenly decide to come back to life and catch up to themselves minutes later. Since writing this I see a few people saying updates are causing MUI apps to fail. I'll try going back in time an update or two when I get home tonight to see if Chrome behaves any better.
Last edited:


Super Moderator
Staff member
Trix are for kids and chrome is for bumpers n trailer hitches; silly rabbit. :D

While your at it you might try the Beta channel version just for Kix.


Active Member
I have attempted to do system restore twice to try to find out if an update did something to make Chrome fail. System restore fails, possibly because (it says) I have AV software running. I turned off Defender and MalwareBytes before trying the restore, so that wasn't helpful.

I have installed the latest beta of Chrome, and it worked great until I shut down the Surface and restarted it, at which point it did the same thing.

So I'm contemplating doing a full system restore this weekend, which I'd rather avoid...