What's new

Surface 2 stuck in "Shutting Down"

jcornwa1

New Member
I have just bought a 64GB Surface 2 a few days back. I tried to shut it down about 24 hours ago (by holding down the off-on button on the top edge). Since then it has been shutting down ever since. The only two screens I get is the blank power saver screen and the one saying "Shutting Down" along with the circle of dots signifying wait. The only strange thing before I tried toi shut down the machine was that I tried to install Dominoes from the Store and it never installed so I tried to cancel the install but it just kept saying installing. I don't have a separate keyboard and nothing works except the on-off key which brings up the shutting down screen. I've tried holding down the on-off button for several seconds and it does nothing. Any ideas please?
 

benjitek

Active Member
Sounds like you got a dud -- did you call support? Better still, since you've only had it a couple weeks, just have the place you bought it swap it out for a replacement.
 
Search tags for this page
microsoft surface stuck on shutting down
surface 2 stuck shutting down
surface pro 2 stuck on shutting down
surface pro 3 stuck in shutting down message
surface pro 3 stuck on shutting down

surface pro 3 stuck shutting down

surface pro stuck on shutting down screen
surface pro stuck shutting down
surface shutting down
surface stuck on shutting down

Members online

Top