What's new

Solved Surface Hub not workng

Muziko

New Member
When I try to use the app "Surface Hub" I get the well known error that the app cant connect to my pen and that I should refresh 3 times on the devices window etc.

I tried everything (reinstalling the app, restarting the surface, repairing the pen to the surface, ...) but nothing worked. I did not reinstall the whole surface but I just don't want to do this for this app, so that it might work.
Do you guys have any more ideas?
I'd really appreciate to use the pen for drawing too. Writing ist not a problem but the intensity is too low for apps like Freshpaint.
 
OP
M

Muziko

New Member
Thanks :)

I did the mentioned steps, as the app asked me to do. This didn't work. I tried it in combination with all of the above mentioned things.

What about this?
But for this to work, you need to get sure you have the 2 last updates for PEN in your surface! Other wise it will not work even this 5 steps. I had this problem and was because of one update was missing

How do I know if I have the 2 last updates for PEN? I downloaded every available update though, so I guess I got it.
 

Liam2349

Active Member
Open Surface Hub, and restart the app. You can do this by dragging it down to the bottom of the screen, hold it there until the tile flips, and drag it back up.
 
OP
M

Muziko

New Member
I know how to restart the app and I did that, as well as reinstalling, rebooting, and so on. This thing does not work on my device, at least not when performing any of these standard tasks :/
 

Liam2349

Active Member
I know how to restart the app and I did that, as well as reinstalling, rebooting, and so on. This thing does not work on my device, at least not when performing any of these standard tasks :/

Have you tried restarting your Surface?
 

sharpuser

Administrator
Staff member
I had this problem, too. But this worked for me:
Control Panel, View Devices and Printers, context-click Surface Pen, Properties, Hardware tab, choose Surface Pen, Properties, General tab, Change Settings, Driver tab, Uninstall, OK, close all windows.

Then press the pen button. Everything loads up and begins working. Hub installs and runs, too.
 
OP
M

Muziko

New Member
I deinstalled the driver now, as you said. Had to reboot the system until my pen worked again (driver is installed). Still Surface Hub won't work :/
Damn.
 
OP
M

Muziko

New Member
I'm pretty sure I did it like it was described but I'll try to find a video or something to make sure. I've also read about others who couldn't get it to work but then again maybe they also got the steps wrong. But actually I'm pretty confident.

Maybe it just won't work for me. Writing is okay so I guess the main purpose of the pen is covered.
 

Snickers

New Member
Strangely enough Virtualbox stopped the hub from working for me - it looks like something VM related captured Bluetooth. Uninstalled it and then Surface Hub worked.

Just my experience tho.
 

Members online

Top