What's new

Surface Pro 3 touchpad issue

parag14

New Member
Hi,

I have a Surface Pro 3, and this issue has been plaguing me, pretty much from the beginning.
Tapping on the touchpad and then releasing it doesn't release the mouse pointer. I can't click on anything else, as the mouse pointer is still not released. I can only get it to release by actually pressing on the touchpad every time, which is irritating to say the least. Does anyone know a solution to this? My Windows 10 is up to date, so that's not an issue to say the least.

PS: Apologies if this problem isn't clear. Please let me know and I can clarify anything. Thanks in advance!
 

hughlle

Super Moderator
Staff member
Welcome to the forum parag14

I'm afraid I have no solution to your problem but recently noticed the same thing on the SP3 my partner uses also on an up to date version of windows 10.

I uninstalled and reinstalled all type cover drivers, didn't appear to help. Did a restart, and it worked again, for a while, but am not sure at this time exactly which action temporarily fixed it.
 

Members online

Top