What's new

Windows 10 Preview on Surface Pro 3

Status
Not open for further replies.
OP
sharpuser

sharpuser

Administrator
Staff member
These screenshots are for the enjoyment of @mitchellvii :)

Screenshot (184).png


Screenshot (185).png


Screenshot (187).png
 

ScottyS

Active Member
My experience with my HP printer is the same. HP has a MUI app, HP AiO Remote, in the MS Store that works great in both Win8 and Win10.
 

GTiceman

Active Member
My Canon MP620 has been working well. I have been using the built in Scan application which takes a moment. It works wirelessly.

I did notice last night, like others have stated, the MS WiDA doesn't work. MY SP3 connects then disconnects with no image visible.
 

erandhawa

New Member
I caved and reinstalled windows 10 preview. Been using it for about an hour now and haven't had any issues. Haven't done anything to system intensive, upon my initial install I was having excessive fan use but as soon as I disabled Diagnostic Tracking Services the fan went silent instantly. Someone did mention turning of IP Helper might help as well for anyone having issues.
Now that I got that out of the way I was first using the Technical preview a few months after the initial release, I would definitely have to say it has come a long way since. I do see improvements in the GUI all around, can't say much about speed just yet but the system seems stable.
I will make sure to update any glitches or quick fixes I find on my way hopefully I will stick with this until the official release this time.
 

erandhawa

New Member
Your crave made you cave.
Welcome back to the Windows 10 pioneers.

View attachment 5494

Yup, I was constantly reading this thread, had downloaded the iso a while ago just didn't install.

What web browser is everyone using? I did notice internet explorer is also a culprit in high fan use. I changed over to chrome and haven't had any issue. Does Opera or Firefox work better? Or maybe another browser? I've read for Windows 8 internet explorer is the best for battery life but with the fan on time with Windows 10 I think those stats may not be the same.
 
B

B'midbar

Guest
Yup, I was constantly reading this thread, had downloaded the iso a while ago just didn't install.

What web browser is everyone using? I did notice internet explorer is also a culprit in high fan use. I changed over to chrome and haven't had any issue. Does Opera or Firefox work better? Or maybe another browser? I've read for Windows 8 internet explorer is the best for battery life but with the fan on time with Windows 10 I think those stats may not be the same.

Waterfox on power, Internet Exploder MUI when off.
 
Status
Not open for further replies.

Members online

Top