What's new


New Member
Good day everyone,
I was wondering if someone could give me a hand this the issue I'm facing.

After reseting my install of W8 on my tablet (in order to leave it to a friend), the network driver was not installed and an error 10 appeared on the device manager saying that the driver is not there. The Device manager sees the hardware name Mavell AVASTAR Wireless-N Network Controller and the driver there is dated from 2013-11-21 and it is version 14.62.28058.10171. I tried contacting Microsoft about this but they asked me to install my OS again using the recovery key; sadly, this did not worked as well. I've been looking over the net for a driver for this Network controller but I do not find any, also no bluetooth because I think both drivers are connected together in a way. BTW my Surface is the Surface 2. Any help would be appreciated, even if someone would have a working S2 and could copy the driver repository for this driver (I can provide with the name of it) it would really help....cheers everyone :):)