What's new

SP3 WiFi problems after January firmware update


New Member
I upgraded my SP3 to Windows 10 and shortly thereafter automatic updates installed the January update. While the WiFi works, it only works if the SP3 is sitting in the same room as the router. It used to be fine sitting in the lounge some 10 + metres away and now it won't connect or is extremely slow. An iPad in the same location is fine as are my windows phones!!
A "sfc /scannow" run claims there were corrupt file errors that it could not fix. The errors relate to a file "opencl.dll" and the rest reference files that are "not owned" or have duplicate ownership. But basically everything works fine apart from that. I have tried re-installing the WiFi drivers to no avail. There is also one other interesting issue, the surface can ping all the computers in the home network, but no one can "ping" the surface it returns a timeout error. Even when I initiate the ping from the router it still times out, yet internet access is fine as long as you sit next to the router!

Any suggestions would be welcome and while a "clean install" is not ruled out it's not that simple because my original UK purchased Surface had a screen fault and was replaced by Microsoft; but because I was living in Spain I had to take one with Spanish language and all the hassle of installing all the language and voice packs to make it "English" is something I would like to avoid!!


Well-Known Member
Welcome to the forum

The sfc /scannow has proven to be pretty unreliable probably due to a big somewhere in the OS. Just because it reported errors doesn't mean you rally have those errors. You could opt for a refresh of Windows for starters.. That would be fairly painless and it might help.


New Member
Ah yes, I forgot to say that a "Reset" doesn't work either as it tells me it can't find the "Recovery environment"!!!


Super Moderator
Staff member
Rumors are floating about there's a fix coming for the sfc error(s).
Some claim to have fixed it but reading the descriptions it looks more like persistence than a repeatable process.

There was a registry setting fix/workaround for WiFi issues... have you tried that?

1. Navigate to the following path: HKEY_LOCAL_MACHINESYSTEMControlSet001Servicesmrvlpcie8897

2. Find the item labelled “TXAMSDU”. Double tap and modify the value from 1 to 0

3. Restart the Surface.
Last edited:


New Member
Thanks greyfox7, while I am not sure that was the answer, selecting a specific channel on the Router rather than allowing "Auto" seems to have solved the problem. It is possible that interference from other networks may have prevented good reception at distance. As I said it worked fine if you were within 1 metre or so, but now it's fine at 10+. However, it still hasn't solved the "ping" issue. I still can't ping the surface or get it to register on the local network, but hey ho the immediate issue is resolved.

Members online

No members online now.