What's new

Surface Pro 10/4/2013 Firmware Update

demandarin

Active Member
Just a heads up, waocom just released a newer updated driver version. For me it seems to have improved pen calibration. Especially near the edges. Also my pen cursor is now directly underneath the tip vs. Before where it was a little off to the right. I didn't even recalibrate after updating driver and notice the improvement immediately. Just wanted to let you all know until I find that pen thread to post this link in also. Go get the update asap.

Wacom Feel Driver | Wacom Americas
 

KR_HyeonBari

New Member
I'm Korean, therefore I can't speak english very well,,, please understand even if your can't understand me clearly

I updated 2013-10-04 version. By the way, after update, problem happened. In touchcover and volumeButten, and touch part(ex touchPen, finger touch) SO Result checking in device manager, yellow flag was registered in touchCover article. HID_sensor too.

this Bug are showing now several people in Korea, and Our community site is so small scale.... that result... now We are not catching way...

P.s My Surface Pro is not 8.1rtm
PP.s I want to get response about this reply to mail. tlgus7777@naver.com
 
Last edited:

cmergel

Member
Hey all, wanted to provide my experience with this update. I updated my Surface Pro 1 yesterday, which has Windows 8.1 Pro RTM on it. It updated without issue, except for downgrading my Intel Graphics from version 10.18.10.3282 (08/26) down to 10.18.10.3262 (07/31). I also noticed other updates from Device Manager, (I'm trying to keep track of what changes, my OCD kicking in). There might be some inaccuracies since there wasn't an official firmware release in August for Windows 8.1. I manually updated some of the drivers.

This is what changed since then (that I noticed).

In Device Manager:
Bluetooth - Marvell AVASTAR Bluetooth Radio Adapter (08/02/2013) -> v14.69.24039.134 | [OLD] (03/05/2013) v14.69.17064.93
Firmware - Surface Pro System Aggregator Firmware (09/18/2013) -> v2.3.250.0 | [OLD] (04/11/2013) v1.4.18768.0
Firmware - Surface Pro UEFI (08/27/2013) -> v1.5.50.0 | [OLD] (07/05/2013) v1.4.350.0
Human Interface Devices - Surface Type Cover Firmware Update Device (09/05/2013) -> v1.0.271.0 | [OLD] (05/03/2013) v1.0.245.0
Imaging Devices - Microsoft LifeCam Front (08/08/2013) -> v4.25.525.0 | [OLD] (04/09/2013) v4.25.523.0
Imaging Devices - Microsoft LifeCam Rear (08/08/2013) -> v4.25.525.0 | [OLD] (04/09/2013) v4.25.523.0
Keyboards - Surface Type Cover Filter Device (08/21/2013) -> v1.0.268.0 | [OLD] not sure
Network Adapters - Marvell AVASTAR 350N Wireless Network Controller (08/02/2013) -> v14.69.24039.134 | [OLD] (05/14/2013) v14.69.24026.106
System Devices - Surface Accessory Device (09/05/2013) -> v1.0.271.0 | [OLD] (03/14/2013) v1.0.217.0
Universal Serial Bus Controllers - Realtek USB 3.0 Card Reader (08/27/2013) -> v6.2.9200.30166 | [OLD] (08/29/2012) v6.2.8400.30143 (questioning the date that I wrote)

I have not been able to find the physical download to this file like the other firmware releases. I like to extract and view the guts.

Thanks.
 
Last edited:

oion

Well-Known Member
I'm Korean, therefore I can't speak english very well,,, please understand even if your can't understand me clearly

I updated 2013-10-04 version. By the way, after update, problem happened. In touchcover and volumeButten, and touch part(ex touchPen, finger touch) SO Result checking in device manager, yellow flag was registered in touchCover article. HID_sensor too.

this Bug are showing now several people in Korea, and Our community site is so small scale.... that result... now We are not catching way...

P.s My Surface Pro is not 8.1rtm
PP.s I want to get response about this reply to mail. tlgus7777@naver.com
Since this looks like a region-specific bug, you're better off trying to contact Microsoft support in Korea directly.
Microsoft ?? | ?? ? ???
Microsoft Worldwide Sites
 

cosmie

New Member
The update is failing for me. It sits (up to an hour) on the Please wait while we install a system update screen until I manually kill it and restart. It also seems to have borked my Type cover in the process, although Device Manager shows nothing wrong with it. A system restore didn't even help. :sorry:
 

demandarin

Active Member
THIS slew of recent updates installed very fast for me. So fast I had to double check to make sure it did it right. They all installed and I double checked for newer updates and none except that optional Bing desktop one.

I will cross reference new versions listed above with mines. IM still on win8 pro though.

Edit: seems like I have most of the ones the poster above has. Except for a few newer ones he has. IM figuring its because he's on 8.1. like the Marvell one and life cam ones.

I need to plug up my type cover then check for update again so I can get those updates also. They won't show up unless keyboard attached.
 
Last edited:
Search tags for this page
download october 5, 2013 surface pro firmware

october2013surfacepro2.zip download

sirface pro firmware windows 8.1 developer rtm

surface firmware october

surface pro 10/4 firmware

surface pro 4 firmware update

surface pro firmware october 2013

surface pro firmware update

surface pro october firmware update

surface pro please wait while we install a system update

Members online

Top