What's new

Official I received my Surface Book

skim175

New Member
I just received mine (i7, 526GB). I had to order through my work place vendor so it took almost 2 months to receive it. Then I had to go through an interesting hiccup. When I fired it up, it DID NOT go through a typical new Windows computer setup process. It went straight to the log in page. Everything was locked so I couldn't even turn on the WiFi. I called a tech support and a tech person told me that it is not uncommon that this happens as an engineer forgot to go through a reset process after the testing. However, after purchasing so many computers, this is the first time ever happened to me. She took me through the hard-reset (basically holding down a power button for 30 sec etc). However, it did not work for a while and it went into UEFI screen. She had to talk a supervisor after struggling for 30 min. While I was on hold, I tried it again. I got a reset/windows reinstallation screen. After an initial setup screen (asking for language, region, etc) and then I was asked to enter Windows "Product Key." I couldn't find this on anywhere (case, adaptor etc). I called a tech support again but she (a different person) repeated that there is no Windows Product key for Surface any more and I am not supposed to get it. She once again talked to her supervisor and told me to skip this and proceed. Everything seemed okay since I finally setup it up even though it did not ask to pair up a pen. Since I kind of finished my process, a tech support person told me that everything is fine. I started installing usual stuff and wanted to change some background. Then I got a message saying that I need to activate my windows. I called a tech support again and I was told that system setup was not properly done so I have to download Surface recovery image and install it. #&R*@&#. Instead of this suggestion, I decided to re-install windows again. This time, I did one thing differently. I clicked "yes" to delete TPM. I don't know whether this was the reason but finally everything worked and got a proper setup process including a pan pairing. Finally I installed all the updates and my software today. After all of these hardships, (knock on woods) I don't seem to have any strange problems reported here with mine yet.
 

compnovo

Active Member
I finally gave in and picked up the base model at Best Buy yesterday, then stayed up too late setting everything up (although setup went smoothly). Since it's similar in power to my SP3 the performance is great, just what I was expecting, and now I can multitask more intensely with the extra RAM. The screen and keyboard are terrific. No problems so far, just happiness, but I'll be posting if I run into any problems.
 

bangsters

Member
I listed my book for sale in this gorums buy/sell/trade section, if anyone wants a near new book at a siginificantly lower price
 

cakebatter

New Member
I just picked up a Base model on 7/3 for web browsing and art, and I'm impressed with the size of the display. So far the only issue I had was the blinking release button, but a reboot cleared it.
 

nnthemperor

Member
Yeah, took delivery of a near new i5/256gb/8g/dgpu SB that I bought from Amazon warehouse deals. Wanted to get bangsters i7, but couldn't find anyone to pick it up for me in the U.S (I'm in Japan). Still saved almost $500 on an almost perfect unit. Completely set up, so far no single problem(knock on wood). My teenage daughter inherited my almost two years old SP3. That too ran without a single problem. Really loving this device. Not sure I can buy a pc from any other OEM.

Sent from my SC-01F using Tapatalk
 

s1301950

New Member
so... i got fed up with waiting for sb (i7 512gigs pb) from ms store (fedex still says label created). so i went and got one from bestbuy. Everything looks great. but i couldn't do what i normally do to all pcs - size down the os drive and create a data drive. I got a 512 gb ssd, but it says the biggest partition i can get out of the main partition is 10gigs.

I've also tried to boot to usb to install a new window, but couldn't change boot order.

any idea?
 

Dblkk

Member
so... i got fed up with waiting for sb (i7 512gigs pb) from ms store (fedex still says label created). so i went and got one from bestbuy. Everything looks great. but i couldn't do what i normally do to all pcs - size down the os drive and create a data drive. I got a 512 gb ssd, but it says the biggest partition i can get out of the main partition is 10gigs.

I've also tried to boot to usb to install a new window, but couldn't change boot order.

any idea?
You've got to use a partition master program. Believe MS in both SP and SB put OS and recovery partitions on opposite ends of the SSD , so move them both to the beginning or end, and then you can chop up the remaining partition.

I know that's not technical lingo, but it's why that's happening. I used Macrim partition manager program, free trial.

Sent from my SM-G935V using Tapatalk
 

s1301950

New Member
ah dblkk, that makes perfect sense. thanks.

how about booting from usb and reinstall windows. do i need to disable secure boot for that? after i did that, the bitlocker gets in the way.
 

Dblkk

Member
ah dblkk, that makes perfect sense. thanks.

how about booting from usb and reinstall windows. do i need to disable secure boot for that? after i did that, the bitlocker gets in the way.
Ah, can't help out to much there. I always disabled secure boot to install from USB, so yes. But I never used bit locker. My SP is only used for one note and remoting into other machines. Never needed security on it other than a quick pin as a deterrent.

Sent from my SM-G935V using Tapatalk
 

Dr. Dan

New Member
Just got my new Surface Book with Performance Base I7, 512, 16gb Ram yesterday and am almost all done loading my programs. LOVE THIS THING!!. Connected an Xbox one wireless controller to it and playing my Steam Games is amazing. Only issue so far is that website loading times seem to drag compared to my SP3.
 

rolldog

New Member
Just got my new Surface Book with Performance Base I7, 512, 16gb Ram yesterday and am almost all done loading my programs. LOVE THIS THING!!. Connected an Xbox one wireless controller to it and playing my Steam Games is amazing. Only issue so far is that website loading times seem to drag compared to my SP3.
Did you have to use the wireless dongle to pair the wireless Xbox remote or were you able to pair it directly with the surface? I have a Sager gaming laptop that I bought a year or two ago which needed the dongle to connect the wireless Xbox controller, but after one of the Windows updates, I could pair it without the dongle. After getting my Surface Book 2 in a couple days ago, I haven't been able to pair it wirelessly.

Sent from my SM-G955U using Tapatalk
 
Search tags for this page

news

Top