What's new

SB doesn't Autorotate when detached?

Niterider4

Active Member
I had all my options set to Sleep, until I realized that (a) the SB would often not wake from sleep (black screen, keyboard lights up), and (b) the battery would drain while sleeping. To avoid these problems, I changed my options from Sleep to Hibernate.

Now that supposedly the wake from sleep issue has been fixed, I may have to change my settings back from Sleep to Hibernate to get rid of the detach-auto-rotate issue. That would be annoying, because I like to Sleep rather than Hibernate when I take a break from lecturing. However, having to possibly reboot when I come back from a break and the screen won't rotate is more annoying than that.
 

ABswl13

Member
I get this annoying problem as well. It always occurs when my 'Hello' camera doesn't turn on when I boot up my Surface Book to sign on. So these two issues have got to be related somehow. Does anyone know if Microsoft has even acknowledged this issue?
 

Niterider4

Active Member
My Hello camera works fine, although I have turned it off when waking from Sleep or Hibernate.

For me, this problem with detach and auto-rotate seems to occur when the SB goes from being asleep and plugged in to being unplugged and then woken up. In other words, on my desk in my office it always works fine, but when I take it to class, open some documents and try to detach, it doesn't work.

It is becoming REALLY annoying!
 

sharpuser

Super Moderator
Staff member
... this problem with detach and auto-rotate seems to occur when the SB goes from being asleep and plugged in to being unplugged and then woken up. ...
Yes, this is precisely when I sometimes encounter this problem.

Surface Book
- Connected to power.
- Sleeps.
- Disconnected from power.
- Awakened.
- Some apps running prevent detaching.

The apps seem to notice that power was connected before sleeping, and now power comes from the battery. This makes the Surface Book panic.
 

Niterider4

Active Member
I had not considered that it might be the apps (MS Office in my case) which may be causing the problem. I usually load up my apps while attached, because it is easier, and then detach.

As a possible workaround, I am going to avoid loading up my apps when attached, and see if it ever happens when no apps are loaded.

However, I can confirm that this problem never happened before the 2/17/16 updates.
 

Niterider4

Active Member
I can confirm that the failure to auto-rotate after detaching occurs without any apps being loaded. I have just had it occur with nothing but the Windows 10 desktop.

When working properly, the detach key lights up red for a fraction of a second and then turns green. The green "ready to detach" popup appears on the screen, and the click is heard fairly quickly. The screen auto-rotates properly, and the screen detached icon shows the screen as being detached.

When the bug occurs, the detach key lights up red and stays red for several seconds. The green "ready to detach" popup does not appear, and the click takes a much longer time. The auto-rotate popup appears, but the screen does not auto-rotate, and the screen detached icon shows the screen as still attached.

The only fix I have found is a reboot, after which it always works properly again, for a while.
 

Niterider4

Active Member
I now believe this issue (no auto-rotate after detaching) is related to Hibernate.

When all button/lid settings are set to Sleep, and none to Hibernate, the issue seems to go away.

This would also explain why some people have had relief by turning off Fast Startup, since that feature is based on Hibernate.
 

mtmowl

Member
I believe so too. That's what I set all "downtime" settings to Sleep weeks ago, and haven't had an auto-rotate lapse since.
 

Niterider4

Active Member
Picking Sleep or Hibernate is like picking which STD you want to get.

After a decade of persistent issues with Hibernate, many of us immediately turned off Hibernate on every Windows computer. Then, we encountered all the Sleep issues with the Surface Book (hot bag, no wake, freezes, battery drain), and we had to go back to Hibernate as a workaround for these problems. At that point, Hibernate worked fairly well. Now, Hibernate is causing a host of different problems (no auto-rotate, brightness at 100%, keyboard/touchpad unresponsive), so we have had to go back to Sleep as yet another workaround.

Here's a cool new technology: You turn off your computer, it goes off. You turn on your computer, it goes on. Wow! It's the future, I tell ya.
 

mtmowl

Member
Niterider, you asked for help, I offered help. Accept it or not. I don't really care. But snarkiness gets nowhere.
 

Niterider4

Active Member
Sorry, I wasn't trying to be snarky to you at all. No offence intended. I was just giving my thoughts on Windows Hibernate and Sleep over the years and with the SB.

My comment was not aimed at you - sorry if I offended you.

Edit: In fact, I very much appreciate the tip about Sleep instead of Hibernate - it fixed my auto-rotate problem, which was actually a pretty significant problem for me.
 

mtmowl

Member
No problem. I understand venting, having engaged it it myself at times. I guess we'd all like things to have gone more smoothly.
 
Search tags for this page
auto rotate on surface book

surface book autorotate

surface book autorotate on
surface book autorotate screen detach

surface book rotate screen

surface book will not autorotate in tablet mode
surface book will not rotate
surface doesnt auto rotate
surface doesnt rotate screen
surfacebook indows 10 does not rotate
Top