What's new

SB doesn't Autorotate when detached?

Niterider4

Active Member
It's funny for me having to go back and forth between Hibernate (which has basically been a disaster in every version of Windows), and Sleep (which has been a disaster with the Surface Book in particular).

That's why it's pretty much a choice between syphilis and gonorrhea. At the moment, the syphilis auto-rotates, so I'm going with it.
 

Niterider4

Active Member
With everything set to Sleep, and Fast Startup disabled, I have not had the auto-rotate problem for a few days now. It's a welcome relief.

I do get some noticeable battery drain while the SB is sleeping (15% overnight), but I can live with that for now.
 

ABswl13

Member
It's so frustrating that it's taking MSFT so long to fix this issue! Does anyone know if there are any negatives to disabling fast startup? I mean will doing so make my Surface Book boot up noticeably slower?
 

Niterider4

Active Member
I have not noticed any issues from disabling Fast Startup, although I do not shutdown very often. I tend to leave my SB on all the time.

The only issue I see from setting everything to sleep instead of hibernate is some battery drain while asleep (e.g. 15% overnight). In hibernate, I get almost no battery drain. But when waking from hibernate, I often get the auto-rotate issue.
 

ABswl13

Member
I have not noticed any issues from disabling Fast Startup, although I do not shutdown very often. I tend to leave my SB on all the time.

The only issue I see from setting everything to sleep instead of hibernate is some battery drain while asleep (e.g. 15% overnight). In hibernate, I get almost no battery drain. But when waking from hibernate, I often get the auto-rotate issue.
Thanks for the reply Niterider4!

So you don't turn your SB off overnight? Does shutting it off and then starting it up to the Windows 10 screen take longer with fast startup turned off as opposed to when fast startup is enabled?
 

Niterider4

Active Member
I basically leave my SB on all the time - either plugged in overnight or unplugged and sleeping (when not in use) during the day. I don't see any need to turn it off. If I needed to conserve battery power, I would shut it down when not in use.

For me a cold boot takes about as long with Fast Startup disabled as it did before. There might be a difference of a few seconds - I don't know, but it isn't significant.
 

Niterider4

Active Member
I was able to fix the auto-rotate issue (screen will not auto-rotate after being detached) by setting all power settings to Sleep (instead of Hibernate).

Having not experienced the problem for just over a week, I decided to set the lid close action from Sleep back to Hibernate, to see if the problem has been fixed generally.

I am sorry to say that within 48 hours the auto-rotate had reared its ugly head again. Press detach, get an extended red light on the detach key, the auto-rotate pop-up comes up but the screen does not auto-rotate.

I have set all power settings back to Sleep so that the detach function works properly again. The downside is having to live with the Sleep-related battery drain issue and the occasional hot bag.
 

Niterider4

Active Member
After 20 years of Hibernate, Microsoft still can't get it to work properly. Not even on their flagship "ultimate laptop".
 
Search tags for this page
auto rotate on surface book

surface book autorotate

surface book autorotate on
surface book autorotate screen detach

surface book rotate screen

surface book will not autorotate in tablet mode
surface book will not rotate
surface doesnt auto rotate
surface doesnt rotate screen
surfacebook indows 10 does not rotate
Top