What's new

Surface Pro Firmware Update Issues


Active Member
From what I have read there are many way to attempt fixing this and only some of them work and then only some of the time. The same as you I tried all the tricks I could think of. Roll back the driver, uninstall the driver, uninstall and delete the software, depress the on/off switch for 15 seconds, etc. Nothing worked so I just rolled it back to the previous driver and left it that way. This morning after I read your message I went into device manager, firmware, picked the third item down which was no longer called Surface Pro System Aggregator Firmware but just something like "Firmware Resource", and selected update driver, search automatically. In a fraction of a second it said "Update Complete" and I saw the name had been changed to Surface Pro System Aggregator Firmware, and there was no yellow flag. Not content to leave well enough alone and firmly believing that a reboot would bring back the yellow flag, I rebooted. The flag was still gone and the name was still Surface Pro System Aggregator Firmware. So MAYBE I am out of the woods on this one.

I now have this problem again and the RESTART does not seem to work. When I hold the Volume button DOWN (Secure Boot Enabled) and power up it states it is installing a system update but never completes. Rolling back to 1.4.17232.0 1/18/2013 Worked.
Last edited: