What's new

UEFI/Embedded Controller/Aggregator Firmware drivers won't install

res0n0xg

New Member
Hi,

Bought my SP2 used and recently was updating drivers manually.... they don't seem to update via automatic updates anyhow. I updated the drivers under firmware and it installed but each one of them has an issue, either saying did not start or please restart to take effect, and after many restarts, etc. they never work properly? What do these drivers even do? Either way, I hate seeing three driver issues on my SP2, help!!!
 

drolem

Active Member
Updating those drivers/FW can be a bit tricky. What FW versions do you have, what are you trying to update with, and how? Were they fine when you bought the SP2?
 

jrapdx

Member
Hi,

Bought my SP2 used and recently was updating drivers manually.... they don't seem to update via automatic updates anyhow. I updated the drivers under firmware and it installed but each one of them has an issue, either saying did not start or please restart to take effect, and after many restarts, etc. they never work properly? What do these drivers even do? Either way, I hate seeing three driver issues on my SP2, help!!!
Can't say I know a whole lot about the drivers you describe. However, according to device manager on my SP2, all but the UEFI drivers are old (dated 2013-09-06 or 2013-09-27) so I'm guessing are the same as when the SP2 was released in October 2013. The UEFI is from 2013-12-20, but since my SP2 is newer than that, not sure which update contained that driver. Possibly it was already installed on your SP2.

You might try "refreshing" the installation, or perhaps better, if there is a "restore point" you might be able to restore the system to it. With any luck you can get it back to where you started with minimal loss of anything important.

Probably someone smarter than me will have better ideas.
 
OP
R

res0n0xg

New Member
No, they were much older than that. I have no recovery partition for the SP2 either. I manually updated them using the October driver package from Microsoft's website. They just show up as "firmware resource" with a driver from 2006 when I choose to rollback the driver, albeit there is no issue once I do that.

is there a factory sp2 image somewhere I can download?
 
Search tags for this page

surface 2 uefi device cannot start

surface book uefi device cannot start

surface embedded controller firmware cannot start

surface embedded controller firmware could not start
surface pro 3 embedded controller firmware
surface pro cannot install firmware embedded controller uefi surface system aggregator
surface pro embedded controller firmware
surface rt2 uefi

surface uefi cannot start

surface uefi device cannot start

Members online

No members online now.
Top