What's new

Post Your SP3 WiFi/Internet Issues Here

Dan Klinger

New Member
ok. I am at a point where I am ready to visit a Microsoft Store to install this firmware update. Why is it so remarkably a pain in the neck to get this SP3 t0 recognize networks after it awakens from sleep?
Low and behold - the last few weeks updates seem to have fixed my woes - it is now connecting seamlessly. Yay!
 

seyclone

Member
HI:

I'm totally new to this forum. Since I'm a "Snowbird", I'm down in Florida (Home Base New York), and I've been connecting over a very slow Hotel network. I've had no problems thus far. Even on the occasion where I switch over to my Galaxy Note 3's cell network, I've seen no problems. However, I have seen the problem at home with an HP laptop over my home network. The Laptop is running Win-8.1pro. Very often, usually after I let the laptop go to sleep or hibernate, it comes back on with either limited or no Wifi connectivity. The only thing that seems to help is a reboot. I'm guessing that the wifi problem that many Surface users are experiencing is a Win problem and not Surface hardware problem.
 

SteveMac

Member
Now I've been blessed with the "I don't want to let go of the old WIFI network when coming back from Connected Standby". Obviously a quick disable and re-enable of WIFI fixes it (as does a reboot). I've tried to re-install the physical device (device manager / un-install / re-scan) and this doesn't seem to clear the issue.

Any ideas (I've had a good search around, however can't find anything that I haven't tried).
 

bcaliendo

New Member
I have an interesting WiFi problem, and I'm not sure if I should start a new thread, but figured I should come here first.

So I got the SP3 (i5, 256gb) about 2 days ago, and updated everything I could (via automatic updates) and WiFi connecting immediately and has worked fine...but ONLY when using the desktop. Other than using the store to download/update apps, NONE of the apps are working when I try to sign into them (i.e., facebook, spotify, netflix, etc.)...they either say there is no internet connection or some type of loading error. So I am unable to sign in to any of them.

Also, when I first turn on my SP3 and sign in, OneDrive pops up with an error about not connecting to the internet (Error Code 0x800c0005). But this clearly isn't true because I immediately go to the desktop and pull up the web browser and the internet is working fine.

What gives? Internet is obviously connected but none of the apps are working properly, or at all. What can I do?
 

ScottyS

Active Member
My WiFi connectivity problems at work have been solved, and it wasn't the SP3 at the cause. The head of our IT upgraded all the WiFi access points over the holidays last month and every since I connect just about everywhere. Still I occasionally get the limited connection coming out of sleep but resetting the wireless adapter fixes that every time (a known SP3 problem).

Ironically, our head of IT told me that after the upgrade the Surface RTs had trouble connected and he had to run a patch on each access point to fix.
 

stonerwinst

New Member
I have been a SP3 owner since the product launch. I have been having the WIFI "limited" issue since day 1.

With the latest January 2015 patch, I think the issue may be solved. The WIFI seems to reconnect automatically now without toggling it off/on.

Any with their WIFI issues fixed from the patch, as well?
 

_SMC_

New Member
I have been a SP3 owner since the product launch. I have been having the WIFI "limited" issue since day 1.

With the latest January 2015 patch, I think the issue may be solved. The WIFI seems to reconnect automatically now without toggling it off/on.

Any with their WIFI issues fixed from the patch, as well?
Yes, it looks like they finally fixed the bloody thing!
 

Buddn

New Member
So everything has been going fine with my SP3 since I bought it (did have a little bit of WI-FI troubles for a bit but an update took care of that a few months back). Well....since the last update my WI-FI has been horrible. I'm getting barely 2 mbps whereas my phone is getting 21 mbps in the exact same spot. Help?!!
 

Alex_Z

New Member
I'm starting to hate the SP3.

After having to refresh Windows and spent half a day re-configuring the thing just to get a keyboard working, just a few days ago spending hours trying to sort out the power button working incorrectly, my wifi has now collapsed and I'm completely stuck.

I've uninstalled the driver completely and get an Ethernet Controller device under Other devices. I can update the driver and sometimes it will tell me there's a problem, other times it'll prompt a successful update. However, whatever the outcome, the device is still listed as Ethernet Controller with no driver provider, date, version or signer. And it states no drivers are installed for this device.

I know that refreshing Windows will resolve this issue but frankly speaking, I don't have the time for that. Considering claiming this under warranty. Any suggestions?
 

Joe S.

New Member
Ok, I'm not sure if this belongs here, since this thread seems more directed at wifi problems that have been persistent from right out of the box. Nevertheless, the sticky says "Post all your wifi issues here", so here I go.

I think my wireless controller just died!

I came home from work today and woke my Surface Pro 3 (i7, 256gig). Hmm, no internet, that's strange. I have had absolutely zero wifi issues out of this machine since day one. I fired it up the first time, it found my network, I entered my wifi password, and it's been absolutely golden ever since. I've only had it about a month, so I think Microsoft had all of the early problems ironed out by the time I got mine. I clicked on the network symbol in the task bar, and out pops the Networks bar stating "No networks found." I toggle the wifi off, then on again - no change. Then airplane mode on and off. No change.

Rick
Hi....
Just went through the same thing. Bought my i5/256G/8G SP3 on Thanksgiving day and loved it. Didn't even know there was a wi-fi problem until...

Last Sunday. Worked fine (as usual). Later in the day get back on and notice the tiles aren't updating/no mail/internet etc. Did all you did and noticed a couple more things. In device manager, Bluetooth was gone and I had an exclamation point in USB Controllers with a message something like "unknown device". Also noticed that the double-click on the pen didn't work anymore. So I noticed 3 new problems I hadn't had before. Oh, I also went somewhere else and saw a "no networking hardware" type message... but it just told me that the Marvell Wireless Controller was working properly at the same time. Whhaaattt???

Called MS Support Monday night and the tech had me do everything I had already done - I understand this and of course go along - I want this thing fixed! Last resort he has me go to recovery and has me go to "Recovery - Remove Everything and Re-install Windows". I think why not, I NEED wireless working on this thing. Anyways, no change, all symptoms the same. He said it could be replaced and I took it to my local MS store and exchanged it. Bought the original from MS's online store but had no problems with the local store. So everything's fine again.

Things I notice different in Device Manager now... No Exclamation Points anywhere. Bluetooth's back AND there's 4 items under it... including Marvell Radio Adapter and Surface Pen. Network Adapters has 3 items under it. The original SP3 only showed the Marvell Controller here. But my point is, it just suddenly died and all these things seemed related to one another.

Gotta give props to MS Support. He spent about an hour on the phone with me and I had no problem with the exchange at the local store. FYI, I did the January Firmware update, but don't believe it caused the problem because my problem began 3-4 days after that.

Anyways, I was looking all over the internet to see if anyone else had the same problem I had, but they were all just a bit different... limited connectivity, and doing different things got it working again, etc. even though it was/is a PITA. Your problem mimicked my situation exactly! It just plain out simply died! Did you ever resolve your problem?

Joe S.
 

RichardH

New Member
I'm new to the forum and just recently installed the Jan 15 2015 firmware update. Prior to the update my Wi-Fi "mostly" functioned properly after sleep. This seems contrary to other's experience. It was a rare occasion that I had to disconnect and reconnect to have Wi-Fi functionality. Now, every time I return from sleep the Wi-Fi appears connected but it doesn't appear that I have an internet connection. To re-establish communication I now have to always disconnect and reconnect after sleep. Has anyone had a similar experience and if so is there any settings that I should review.
 
Search tags for this page
sp3 wifi drivers 10074

sp3 wifi issues

sp3 wifi issues youtube
surface pro 3 wifi connects at lower spee when switching networks
surface pro 5g connection issues
surface pro exclamation on wifi
surface wifi problem after windows update feb 2015

wifi issues sp4

wifi slower on surface pro 3 than other devices

windows 10 wifi issues sp3

Members online

No members online now.
Top