What's new

Post Your SP3 WiFi/Internet Issues Here


New Member
So i have a nice new i7 256GB SP3 as of last Friday. Once i'd set it up and had the usual dabble you do with new kit i purposefully updated anything offered on Microsoft's SP3 Support website. This all happened at my work and after allowing the unit to update some 129 Windows updates i shut it down and went home with it.

AT home i have a VDSL WiFi modem/router called a "Technicolor" and the Apple AirPort Utility for the apple gear so effectively there's 3 WiFi connections available. These all work fine and on my Android device i use an app called WiFi analyser that shows where the 5GHz and 2.4GHz SSIDS are channel-wise.

So 1st up i was amazed when the SP3 could not see the modem. I soon discovered the need to go down channel so i changed that on the modem and the SP3 instantly picked it up.

So after a day and a half i tweaked things and became familiar with the SP3 including my support and familiarity with Firefox so that has been installed as my browser ... however here's the problem. I have searched high and low but just can't get my head why if from a cold boot i type directly into the address bar the url for something and for the 1st 10 to 15 mins the page is loaded almost instantly.

I have intentionally ensured i am going to a site that won't have cached either and it loads really quickly.... but after 15mins, things are slowing down, right down, and eventually the infamous time out message appears.

The other kicker is if i use the standard www.Google.com in the address bar and then do a random search for whatever, should i click any of the offered URLs then my SP3 becomes TOTALLY borked and eventually the timeout message appears. The only fix is to go select a new WiFi connection and we are back for fast responses for another 10 to 15 minutes.

Obviously my SP3 has a connection problem and i have waded through so many posts on 100s of sites on this but i really do not know just what i should be doing. None of my mobile gear has ever been this flakey.... I find it interesting, if not hilarious using a Google Search can kill my Sp3. I understand there's been some kind of issue with the Marrel AVASTAR Ethernet controller and its engagement with WiFi access. My machine shows Ver 15.68.3073.151 which i believe is the latest so i dunno....

I 'm sure someone here will be able to put me right on why my SP3 isn't holding on to its WiFi internet connection... thanking you in advance.


Super Moderator
Staff member
... Firefox ... has been installed as my browser ...
1) Does the same thing happen with Internet Explorer?
We should start there to make it easier to isolate the problem.

2) It could be that you are experiencing OneDrive still doing its initial syncing and setup for you. That would really draw bandwidth, and perhaps processing time. As long as WiFi is not disconnecting, let it ride for, say, twelve hours.


Super Moderator
Staff member
Make sure your Router has the latest firmware installed. Disable IPv6 and QOS on your adapter. Change your DNS to &


New Member
Hello sharp... Thanks for posting. Ok i have gone over to IE and to set things a a reference point i connected to the Internet using my Modem's WiFi and marked the time. My 1st test using Google as my homepage resulted in a list that immediately brought up the Blocked PopUp banner warning Google needed to be cleared to do so...

So that done i continued on and clicked some of the URLs offered by the Google Search. Almost all tripped the pop ups warning once again which i noted was set to high and i have now set it to medium.

Getting to a website this way was slow though, sitting on a blank white screen for a 40seconds maybe more with a whirly cranking away to the left part on tab. If on the other hand i cut and paste the URL from the Google Search result list into the address bar, BAM the page appears in a blink of an eye...

I then tried a few other random URLs i know would not have been cached on my SP3 and typed directly into the address bar and they produced a homepage on the site real quick.... BUT! after 12minutes things just became slow as anything and eventually any URL brings up the This Page Can't be Displayed message. Running the Fix Connection reports the URL is not answering.

My next move was to change to a different WiFi source in my home and do a refresh whereupon the webpage appears virtually in seconds. It's the same stuff that's happening under FF. Is my SP3 doing something with its power management perhaps (the 10minutes is indicative) of the input to its ownWiFi module i.e. switching off the connection between the device that manages the computer itself into its own WiFi module? The module is showing as working but it looks like the SP3 is ceasing feeding any data through to it.... ???


Super Moderator
Staff member
Thanks for that info, @peteb2

A couple of suggestions:

1) How about connecting directly to your modem via cable, and see if you get the same slowdown.

2) Your problem may be related to Instant Go or Connected Standby. Turning those off could help. To do so, go to Control Panel > Programs and Features. Tap Turn Windows features on or off, which is located on the left hand side of the window. Make sure that Hyper-V is checked off, and then restart your SP3. Now, go to Control Panel > Power Options and tap Choose what the power buttons do on the left. Then, tap Change settings that are currently unavailable. Uncheck Turn on fast startup
Read more: http://www.digitaltrends.com/computing/surface-pro-3-problems/#ixzz3X34BkkvR

3) Disable, then remove your WiFi adapter, then reboot cold.


New Member
Well i am now at a loss. I have read all the posts here indicating that many SP3 units have had and still have a huge problem with it's ability to maintain a good fast connection to the the Internet over WiFi (fast in the sense of web-page update) . This is something Microsoft have done their best (by now i guess) to eradicate with multiple updates.

The last thing i did yesterday was to give my SP3 a full reset to factory and started again. Then i ran the latest updates for SP3 available from http://www.microsoft.com/en-us/download/details.aspx?id=38826.

The result: after ten or so minutes my SP3 ability to change between URLs while on a WiFi or web-page updates when working on a website (using Internet Explorer) the connection crawled to almost a halt and then after 15mins back came the 'page not available messages'. By changing to a different WiFi we can run well for another 10mins, same pattern of effects...

So no improvement for now which means my SP3 is a dog for now. I know i have just spent what to me is a good chunk of change plus the fact that i have never had such a basic issue like WiFi connection performance issues on my MacBook Pro, iPhone, iPad or my Sony XperiaZ2 Android tablet and WD Entertainment Unit i will box on and find out what exactly is going wrong...

Time to talk with my mates in the IT industry...


New Member
Well an update, mainly to pass on my findings so far (for anyone else caught up in the same set of problems).

I finally have 'some' extended-time stable WiFi internet access. I have had to virtually lock my new SP3 down so that it's on WiFi it ONLY it always accesses the 5GHz Band.

Control Panel ->Network & Sharing ->Basic Network Information then click on active WiFi device for Status ->Properties->Configure->Advanced and chose Band

In my home it just happens that 5GHz is available on my Apple Airport Extreme Base Station which lucky for me happens to have the benefits of 802.11ac which going by other sources of info is the faster data rate WiFi and possibly what allows the SP3's Marvel AVASTAR Wireless-AC Network Controller to perform reliably.

Obviously the Airport Extreme is sitting there mainly for my Macbook Pro to backup to and it's a fluke really i have a 5GHz WiFi option because the main ISP supplied modem/router is 2.4GHz only (802.11g/n) and they have told me they do not have a dual system unit (which is supplied free as part of my contract with them).

My belief here though is that since the Airport Extreme connects to the Modem/Router on a Ethernet network we are just introducing another path of data handling which can't be all that efficient. I've not verified the range either.

One weird thing about the Marvel AVASTAR driver Wireless-AC Network Controller. Although the Driver lists as being the newest 15.68.3073.151 if i run Diagnose on the WiFi Status and the View detailed information, then Detection Details (click down arrow) Trouble shooting report reveals the driver as the previous 15.68.3044.85 so i just do not know....

One other cool thing is i have been able to install the free interface SW and use my Apple Magic mouse and that's a bonus but sometime someone else needs it while they are using the MacBook Pro....


Super Moderator
Staff member
Glad you got that sorted, @peteb2 . I would mark this 'SOLVED', if it was an independent thread.

A couple of comments:
1) I have the Airport Extreme also, bridge connected to my modem. The Airport Extreme is the only device I broadcast 5 GHz from, to avoid conflict.
2) I guess we could have suggested that you tell us if you get the same slowdown away from home. That would have been a good way to tell if it was your SP3 that was causing the problem.



New Member
@ sharp... yes thanks. Will have to do a test. At my work the WiFi DSL modem-router in my office (which provides us with our own independent access to the Internet over the Company's internal locked down and monitored Intranet) is providing both 2.4GHz and 5Ghz options. I'll give it a trial later this week and see what my SP3 does.

Here's some more interesting stuff i found with my SP3. I do a lot of 'hobby time' electronics which involves PCs being made to do all kinds of stuff. It invariably means the USB connect has to have a specific driver up and running to allow certain projects to work properly. That's where i discovered a free program called "Zadig" that lets you look deeply into drivers and just what your PC is doing as it runs under MS Windows...

Zadig can be downloaded here: http://zadig.akeo.ie/

(Note: i have no connection with the people involved in it, nor any financial interest, it's free anyway). .... just my disclaimer. For a background on how simple it is and what it does see: https://github.com/pbatard/libwdi/wiki/Zadig

Anyway, running it on my SP3 i was actually surprised to discover that the attached Keyboard cover and the Marvel AVASTAR Wireless-AC Network Controller are interpreted as individual USB devices (along with the front and rear cameras) and anything you should happen to have plugged into the single USB-3 socket....

This to me is kind of weird because i'd have thought the SP3 would have been designed so that something like Network Controlling would have been done directly on the PCi-e bus. I don't know, i don't design PC mother boards but i guess it could be all about building a small as possible footprint motherboard and that needed USB interfacing that became internal. It's really just academic that's all but real interesting.... to me.

So the best thing about using using Zadig though is that i am able to see and confirm directly what version driver is truly loaded up to take care of the Wifi.

In a couple of weeks i am set to change out my home Internet connection to Fibre (the contractors just tore my street up and blew it all through a few weeks ago) from the now VDSL so we should see an improvement on speed yet again. Interesting the ISP doesn't supply me a free dual-band modem router (its a Huawei HomeGateway HG630b). I will probably be saving up my spare pennies for a Cisco or something because i just know the ISP will have their supplied one locked down to death...


Update on my SP3 Pro wifi connection issues at work. It is on Win 10 Preview version 10074, and I have been able to stay connected at work for the last several days. I can't pinpoint what has changed, but there have been definite changes to at least the user interface for connecting to WIFI, whether or not anything behind the scenes has changed I have no clue. I have been vacillating between it being an access point issue to perhaps a credentials issue with Windows. Who knows, but it has been working properly, knock wood, for the last several days. It is definitely related to the 10074 version, as I have had the same intermittent issues with all the versions of 8.1 and previous Win 10 TP versions.


New Member
I have a work supplied i5 SP3. It has worked great for the last few months and the last week or so I can not open many web pages. It is very strange since about 50% of the sites work fine and others won't open at all or work VERY slowly. I have all of the latest updates, I've reset Internet Explorer a few times as well. Sometimes I can "Forget This Connection" and reconnect and I'm OK for a bit and then it'll slow to a crawl again.

I'm using Win 8.1 and IE11 desktop version. No addons, default settings for IE. I tried setting the network adaptor to 5Ghz and 2.4 Ghz only as well as suggested by another site, but neither helped.'

Any suggestions?
Search tags for this page
sp3 wifi drivers 10074

sp3 wifi issues

sp3 wifi issues youtube
surface pro 3 wifi connects at lower spee when switching networks
surface pro 5g connection issues
surface pro exclamation on wifi
surface wifi problem after windows update feb 2015

wifi issues sp4

wifi slower on surface pro 3 than other devices

windows 10 wifi issues sp3