What's new

Surface PRO Firmware Update...

tonyz3

New Member
My update failed, any idea how to get it to try again?
If you hit the buttone that takes you to the page where it list all the updates. uncheck them all than check one at a time and install one at a time. there may be a few out of order where you check it off and it fails anyway by itself, move on to the next one than come back to any that failed. but update them individually, you may have to restart after each one. but they will all eventually go thru.:angry:
 

seaham358

New Member
I had 7 updates and it failed.. Unchecked them all then tried 1 at a time till I got 1 to go.. After that 1 I could DL the other 6 at the same time.
After it was finished and restarted the pen did not work. Shut off and rebooted after a few minutes, all is well now..
 

socos

New Member
Here's my update story: I was initially getting an instant update fail "Error 80070003". A quick Google search says to delete the files and folders under \Windows\SoftwareDistribution\DataStore and \Windows\SoftwareDistribution\Downloads. After clearing those out the updates came down fine. Most likely cause was me tethering to my phone this afternoon for a couple minutes. It probably checked in with the Microsoft mothership and started to cache the updates. When I disconnected from the tethering session the cached files sat there unfinished. Odd that when I connect at home the updates can't figure out that they're messed up and just re-download.

Anyway!!! The updates appeared to install fine and the first of a few reboots took place. (Surface logo and installing updates at the bottom of the screen) I got a couple reboots and then uh-oh, what was that big temperature icon??? The system turned off so I felt the back of my Surface Pro and sure enough it was running kinda hot (Fans never turned on). I let it sit for a couple minutes fearing the worst (EPIC BRICK FAIL!) Bravely I tapped the power button and it turned right back on with the same Surface and installing updates screen. This time I heard the fans kick on full speed and it seemed to reboot one more time. A sigh of relief as I get to the login screen without issue. Everything looks fine! I grab my stylus and no worky! I read someone's post about shutting it off and back on again so I do that. Stylus back and I see no yellow "bangs" in the device manager.

It will be interesting to see if my WiFi behaves better. I read that the firmware update provides "improvements to "limited" connectivity scenarios". Which I was definitely getting on my router.
 

tonyz3

New Member
That was exciting. Kept me on the edge of my seat. Glad it had a happy ending.
 
Last edited:

bheath3

New Member
Well, just a few hours after installing the firmware update I am back to having limited connectivity. Guess the update didn't work out all the bugs with the WiFi yet. Anyone else still having this problem?
 

jacewt

New Member
I am, In fact I think it is happening more often than before. I run a router and an access point so I switch between the two and everything works again but it is annoying.
 
Search tags for this page
check surface pro firmware version
surface pro 2 firmware update
surface pro 2 firmware update failed
surface pro 2 firmware version
surface pro 3 firmware update
surface pro embedded controller firmware
surface pro firmware

surface pro firmware update

surface pro system firmware update
system firmware update surface pro

Members online

No members online now.
Top